PDA

View Full Version : Why my opengl application is slower in a pc with geForce4?



Puma1140
12-25-2003, 05:23 AM
I've programmed and compiled an opengl application in my pc (pentium II 266, 64 MB Ram, GeForce2). I tested my exe file in a Pentium III 900 Mhz, 512 MB Ram, GeForce4 and it was slower. Why is that?

12-25-2003, 06:45 AM
It can be several things.
A GeForce2 GTS is MUCH faster than a GF4 MX, for example.

Or, the correct drivers are not installed, so the program falls back to software emulation.

Can your detail what your program actually draws ? Many polygons ? Few large blended polygons ? Multitexture ? Is there antialiasing enabled on the gf4 ? etc.

Puma1140
12-25-2003, 06:55 AM
It draws a cube with the same texture on every quad of it. Inside the cube there is a textured sphere. By pressing 'b', blending is enabled and you can see the sphere inside the cube. By pressing 'l', lighting is enabled and by pressing 'f', fog is enabled. By moving mouse, you can rotate the cube and the sphere. I also tested another program I've made where I've rendered a quad and its reflection on a textured floor. By pressing the keys left or right, you move the quad left and right. This application is slower too when running in GeForce4

JanHH
12-25-2003, 06:11 PM
what happens when you do not use the exe files, but compile the program again on the faster computer? maybe you are statically linking some libraries that are "wrong" for the faster computer?

zeckensack
12-26-2003, 09:20 AM
Turn off VSync.