PDA

View Full Version : Performance Hit Using 16 bit ???



stryx
03-24-2002, 01:28 PM
Hi, If I start my engine at 800x600 (my screen doesn't support more) I have around 61 to 80 frames on a 450Mhz Celeron with an TNT2 M64 (detonator 28.32 downloaded today)

When I switch to 16 bit i get 4-7 fps !!!
What's wrong ?????
Please Help !!


EDIT:
SOME USEFUL INFO:

800x600x32 Fullscreen......80-90 fps
800x600x16 Fullscreen......2-6 fps
800x600x32 Window..........65-70 fps
800x600x16 Window..........60-70 fps

640x480x32 full............90-100 fps
640x480x16 full............5-10 fps
640x480x32 window..........70-75 fps
640x480x16 window..........100-105 fps

It seems that fullscreen with 16bit is the problem, but why ??

(Can it be the detonator drivers ?)

[This message has been edited by stryx (edited 03-24-2002).]

DFrey
03-24-2002, 01:51 PM
Probably due to OpenGL being forced into a software path due to you using something in 16 bit mode that isn't supported by hardware in 16 bit mode. Most likely stencil buffering.

stryx
03-24-2002, 02:09 PM
Yeah , stencil buffer, that's it.

Thanks !
(bye bye 16bit world http://www.opengl.org/discussion_boards/ubb/wink.gif

nexusone
03-24-2002, 02:50 PM
One thing is that most video cards 3D hardware are made to run at 32 bit color.
Under 32 bit you may not be getting the hardware working at optimum preformance or all of it being done through software only due to it being at 16 bit.

Diffrence between full and windowed maybe the size diffrence. A smaller area to render speeds up the process.


Originally posted by stryx:
Hi, If I start my engine at 800x600 (my screen doesn't support more) I have around 61 to 80 frames on a 450Mhz Celeron with an TNT2 M64 (detonator 28.32 downloaded today)

When I switch to 16 bit i get 4-7 fps !!!
What's wrong ?????
Please Help !!


EDIT:
SOME USEFUL INFO:

800x600x32 Fullscreen......80-90 fps
800x600x16 Fullscreen......2-6 fps
800x600x32 Window..........65-70 fps
800x600x16 Window..........60-70 fps

640x480x32 full............90-100 fps
640x480x16 full............5-10 fps
640x480x32 window..........70-75 fps
640x480x16 window..........100-105 fps

It seems that fullscreen with 16bit is the problem, but why ??

(Can it be the detonator drivers ?)

[This message has been edited by stryx (edited 03-24-2002).]

zed
03-24-2002, 10:07 PM
>>800x600x32 Fullscreen......80-90 fps
800x600x16 Fullscreen......2-6 fps
800x600x32 Window..........65-70 fps
800x600x16 Window..........60-70 fps

640x480x32 full............90-100 fps
640x480x16 full............5-10 fps
640x480x32 window..........70-75 fps
640x480x16 window..........100-105 fps

It seems that fullscreen with 16bit is the problem, but why ??<<

cause your desktop screen is set to 32bit colour
ie window will use the same depth as the desktop (unless u go fullscreen + in doing so change the desktops colourdepth)