PDA

View Full Version : I can compile GLUT 3.7, but I can't run it!



Demiurge
03-09-2003, 09:37 AM
Hi,

I keep getting the following runtime error message:

"The GLUT.DLL file is linked to missing export OPENGL.DLL:glPopAttrib"

Now, I went to NVidia to download the latest drivers for my video card. I downloaded the latest version of GLUT. The program compiles perfectly, but I keep getting this stupid runtime error!

Does anyone know what I'm doing wrong, or how I can convince GLUT to use NVidia's OpenGL 1.3 drivers instead of the outdated OpenGL 1.1 drivers that came with Windoze?

Any help would be appreciated! Thanks!!!

--Jonathan

mikael_aronsson
03-09-2003, 10:28 AM
Hi !

It does sound weird, but if you can link the application and get the error when you run it, then you should have the glPopAttrib in the opengl import library, but then you might have a smacked or unmatching opengl32.dll, shouldn't the message say OPENGL32.DLL instead of OPENGL.DLL ? not sure if it does, OPENGL.DLL is the old dll used by sgi's opengl software driver outdated long ago, not sure if that has anything to do with it.

If you are running anything later then Windows95, then your opengl files should be correct unless you have messed something up.

Sorry, running out of ideas here.

Mikael

Demiurge
03-09-2003, 10:51 AM
Yeah, and for that matter, why's it GLUT.DLL and not GLUT32.DLL?

I must have screwed something up along the way... or maybe GLUT 3.7 is expecting me to have updated OpenGL drivers, except that I can't seem to find any generic OpenGL drivers that aren't 7 years out of date. And GLUT obviously doesn't care about my updated NVidia drivers... maybe I should bring this up with GLUT's author?

Right now I'm trying to run GLUT as a console application. It was running fine that way at school (on Windows 2000). Maybe if I switch to using a WinMain instead of Main and GLUT, then it'll automatically use my NVidia OpenGL drivers?

--Jonathan

Demiurge
03-09-2003, 11:01 AM
Woohoo!!! Problem solved!!

In case anyone's interested in what the problem was:

In my VC++ project settings I had told VC++ to link GLUT.LIB. When I took this out of the project the error message went away and the program ran perfectly.

Don't I feel silly! :-P

Ciao,

Jonathan