PDA

View Full Version : Need Newer Version or My Mistake?



Galileo430
06-28-2000, 12:51 AM
Bare with me this take a second to explain,
I has working on the HeNe Lesson 6 when it would not compile. Here is the 2 messages I got, (not I compressed these a tad for the forum but this is the "IMPORTANT" parts)

'glGenTextures' : undeclared identifier, term does not evaluate to a function

'glBindTexture' : undeclared identifier, term does not evaluate to a function

So I checked my copy of OpenGl documention that came with my copy of VC++ 4.0 I see that those functions are not in there. Do I need a newer copy of OpenGL if so where can I download a copy?

MikeC
06-28-2000, 01:26 AM
Those functions have to do with texture objects, which were added in OpenGL 1.1. They're in my MSVC6 docs.

You can get the 1.1 binaries from Microsoft (link on this website somewhere); it won't give you the updated docs, but all that stuff is in the Red Book anyway.

Galileo430
06-28-2000, 02:53 AM
Thanks..