PDA

View Full Version : Draw Faster



Swift
02-05-2003, 04:43 PM
I am doing a small project to display schmatic of PCB. It is quite similiar to a Gerberview. However, refresh rate of the display is quite slow for more compilcated PCB. Thanks

rIO
02-05-2003, 11:48 PM
A question whould for sure help giving an answer...

03-15-2003, 08:07 AM
can you help me these are my errors

--------------------Configuration: glutrad - Win32 Debug--------------------
Linking...
glutrad.obj : error LNK2001: unresolved external symbol _glutPostRedisplay@0
glutrad.obj : error LNK2001: unresolved external symbol __imp__glReadPixels@28
glutrad.obj : error LNK2001: unresolved external symbol __imp__glPixelStorei@8
glutrad.obj : error LNK2001: unresolved external symbol __imp__glCallList@4
glutrad.obj : error LNK2001: unresolved external symbol _gluLookAt@72
glutrad.obj : error LNK2001: unresolved external symbol _gluPerspective@32
glutrad.obj : error LNK2001: unresolved external symbol __imp__glLoadIdentity@0
glutrad.obj : error LNK2001: unresolved external symbol __imp__glMatrixMode@4
glutrad.obj : error LNK2001: unresolved external symbol _glutIdleFunc@4
glutrad.obj : error LNK2001: unresolved external symbol __imp__glEndList@0
glutrad.obj : error LNK2001: unresolved external symbol __imp__glEnd@0
glutrad.obj : error LNK2001: unresolved external symbol __imp__glVertex3f@12
glutrad.obj : error LNK2001: unresolved external symbol __imp__glColor3f@12
glutrad.obj : error LNK2001: unresolved external symbol __imp__glBegin@4
glutrad.obj : error LNK2001: unresolved external symbol __imp__glPolygonMode@8
glutrad.obj : error LNK2001: unresolved external symbol __imp__glShadeModel@4
glutrad.obj : error LNK2001: unresolved external symbol __imp__glClear@4
glutrad.obj : error LNK2001: unresolved external symbol __imp__glClearColor@16
glutrad.obj : error LNK2001: unresolved external symbol __imp__glNewList@8
glutrad.obj : error LNK2001: unresolved external symbol _glutSwapBuffers@0
glutrad.obj : error LNK2001: unresolved external symbol __imp__glRotatef@16
glutrad.obj : error LNK2001: unresolved external symbol "void __cdecl AliasPerspective(int)" (?AliasPerspective@@YAXH@Z)
glutrad.obj : error LNK2001: unresolved external symbol _glutMainLoop@0
glutrad.obj : error LNK2001: unresolved external symbol __imp__glEnable@4
glutrad.obj : error LNK2001: unresolved external symbol _glutAttachMenu@4
glutrad.obj : error LNK2001: unresolved external symbol _glutAddMenuEntry@8
glutrad.obj : error LNK2001: unresolved external symbol _glutCreateMenu@4
glutrad.obj : error LNK2001: unresolved external symbol _glutReshapeFunc@4
glutrad.obj : error LNK2001: unresolved external symbol _glutMotionFunc@4
glutrad.obj : error LNK2001: unresolved external symbol _glutMouseFunc@4
glutrad.obj : error LNK2001: unresolved external symbol _glutSpecialFunc@4
glutrad.obj : error LNK2001: unresolved external symbol _glutKeyboardFunc@4
glutrad.obj : error LNK2001: unresolved external symbol _glutDisplayFunc@4
glutrad.obj : error LNK2001: unresolved external symbol _glutCreateWindow@4
glutrad.obj : error LNK2001: unresolved external symbol _glutInitDisplayMode@4
glutrad.obj : error LNK2001: unresolved external symbol _glutInitWindowSize@8
glutrad.obj : error LNK2001: unresolved external symbol _glutInit@8
Debug/glutrad.exe : fatal error LNK1120: 37 unresolved externals
Error executing link.exe.

glutrad.exe - 38 error(s), 0 warning(s)

shinpaughp
03-15-2003, 08:19 AM
Do you have your libraries linked into the project? You can use #pragma comment (lib, "opengl32.lib") and glut.lib and any other libs you use that are not default. Or add them within your project settings. And make sure the libs are in a directory where your compiler can find them, etc, etc.

denson
05-25-2010, 02:37 PM
I'm having the same problem with Visual C++ 2010. I have set up all the links.

I'm just trying to build the sample projects from this, so I'm reasonably sure the program is correct:

http://www.opengl.org/sdk/docs/books/SuperBible/

denson
05-26-2010, 04:40 PM
I got it to work. The problem was that Visual Studio 2010 is not handling paths and link order the same as previous versions.

Here are the changes I made to make it work:

Put the full path instead of the relative path in the include

so instead of ..\..\shared\gltools.h

use c:\full_path\shared\gltools.h

move the #include glee.h to your main project file. You have to make sure glee.h loads before the other includes.

In the gltools.h comment out the #include glee.h

#include <windows.h> // Must have for Windows platform builds
//#include "gl\glee.h" // OpenGL Extension "autoloader" put this in your main project file
#include <gl\gl.h> // Microsoft OpenGL headers (version 1.1 by themselves)
#include <gl\glu.h> // OpenGL Utilities
#include "gl\glut.h" // Glut (Free-Glut on Windows)

denson
05-26-2010, 04:47 PM
Forgot one thing you need to download freeglut and install it, setting up the paths to the .lib and .dll in VS and put #include <gl\freeglut.h> in the gltools.h file