PDA

View Full Version : Dev-Cpp and OpenGL



ShadowHunter
10-03-2003, 02:53 PM
I am using Dev-Cpp and want to start programming in OpenGL, however my compiler cant find the openGL files (glut). please help me.

yaro_dup1
10-04-2003, 06:49 AM
Search the google for GLUT files: glut32.dll and glut32.lib. Your compilator hasn't got these files.

ShadowHunter
10-04-2003, 04:48 PM
I did that, I even included the files in my projects and it still can't find them.

mikael_aronsson
10-04-2003, 11:34 PM
Hi !

I am not sure what you mean with "included in the project", you must tell the linker to use the libraries, DevCPP uses the MinGW/gcc compiler so make sure that the linker does -lglut.lib or -lglut.a, I don't have a clue how to do that from inside DevCPP though.

Mikael

ShadowHunter
10-05-2003, 04:13 AM
Originally posted by mikael_aronsson:
Hi !

I am not sure what you mean with "included in the project", you must tell the linker to use the libraries, DevCPP uses the MinGW/gcc compiler so make sure that the linker does -lglut.lib or -lglut.a, I don't have a clue how to do that from inside DevCPP though.

Mikael


By include I ment, I added the files to the project and I am confused by what you said.

mikael_aronsson
10-05-2003, 10:32 PM
Hi !

You say your "compiler" cannot find the files, are you talking about .h files in that case ? (glut.h) or are we talking about the linker here ? (glut.lib)

Mikael

ShadowHunter
10-06-2003, 06:21 AM
Both, it cant find any of the files.

ShadowHunter
10-07-2003, 05:09 AM
anyone????

nexusone
10-07-2003, 05:29 AM
I am guessing you have downloaded the newest version of Dev-cpp?
Anyway all the openGL files are in the DEV-CPP installation file. Note you have to use a GLUT library created for the DEV-CPP compiler, you can not use just any GLUT library.
I am sure the dev-cpp also had come with the glut library.


No matter what version you have look under project options and linker options:
the settings should look like this: -lopengl32 -lglu32 -lglut32


I have a example of setting up openGL in dev-cpp on my website: www.angelfire.com/linux/nexusone/ (http://www.angelfire.com/linux/nexusone/)


Originally posted by ShadowHunter:
I am using Dev-Cpp and want to start programming in OpenGL, however my compiler cant find the openGL files (glut). please help me.



[This message has been edited by nexusone (edited 10-07-2003).]

ShadowHunter
10-07-2003, 01:05 PM
I cant find any of those files, is there any place I can download them??

nexusone
10-07-2003, 04:38 PM
Did you go to my website???
If you have downloaded and installed the full DEV-CPP package, not just the exe files (about 12 Meg download) from Bloodshed website you have all the files for openGL.

I rechecked the newest version of DEV-CPP (BETA), and it had all of the openGL files including GLUT.

I think a older version DEV 4, did not have the GLUT library in the installation. But you can click on the GLUT link at my website for it.

Note on the DEV library files start with libXXXX.a and not XXXX.lib
DEV-C++(PP)Library files:
/dev-c++/lib
libopengl32.a Note the 32 means 32 bit librarys
libglu32.a
libglut32.a
libglaux.a

INCLUDE files:
/dev-c++/include/GL/
gl.h
glu.h
glut.h
glaux.h



Originally posted by ShadowHunter:
I cant find any of those files, is there any place I can download them??

[This message has been edited by nexusone (edited 10-07-2003).]

[This message has been edited by nexusone (edited 10-07-2003).]

Latrans
10-08-2003, 07:00 AM
I haven't done much with Dev-CPP, but my guess is that it's an ESO problem.

(Equipment Smarter than Operator)

swiych
10-11-2003, 08:56 AM
I am using Dev C version 4. glut.h is in include\gl though I can't remember if it came with it or I downloaded and put it there http://www.opengl.org/discussion_boards/ubb/biggrin.gif

Anyway just put #include <gl\glut.h> in your source file and -lopengl32 -lglu32 -lglut32 in Project-->Options and you should be good to go.




[This message has been edited by swiych (edited 10-11-2003).]

10-12-2003, 10:01 AM
Sorry, but as for as I know GLUT is *NOT* include with Dev-cpp. Try to use GL.h, GLU.h GLAUX.h

And under Options->Compiler Options add the following for the compiler options:
"-lglu32 -lglut32 -lopengl32"