PDA

View Full Version : help .net nvoglnt



Muhson
12-08-2003, 10:59 PM
hello,
i am a student, and i learn opengl.i am working with .net, the problem is, when i tried to execute a program from my class. the program (after the black window opens) should open a white window with stuff on it. i get only the black window and than it crashed. the debug window shows alot of lines but those few lines repeat themselfs:

'rotem.exe': Unloaded 'C:\WINDOWS\system32\vdmdbg.dll'
'rotem.exe': Unloaded 'C:\WINDOWS\system32\psapi.dll'

'rotem.exe': Loaded 'C:\Documents and Settings\Liad\Local Settings\Temp\A5355s._0a', No symbols loaded.

'rotem.exe': Loaded 'C:\WINDOWS\system32\nvoglnt.lrc', No symbols loaded.

First-chance exception at 0x77f69ecd in rotem.exe: 0xC0000005: Access violation writing location 0x00000010.

'rotem.exe': Unloaded 'C:\WINDOWS\system32\nvoglnt.lrc'

'rotem.exe': Unloaded 'C:\Documents and Settings\Liad\Local Settings\Temp\A5355s._0a'

'rotem.exe': Unloaded 'C:\WINDOWS\system32\nvoglnt.dll'

'rotem.exe': Loaded 'C:\WINDOWS\system32\mcd32.dll', No symbols loaded.

'rotem.exe': Unloaded 'C:\WINDOWS\system32\mcd32.dll'

'rotem.exe': Loaded 'C:\WINDOWS\system32\nvoglnt.dll', No symbols loaded.

'rotem.exe': Loaded 'C:\WINDOWS\system32\psapi.dll', No symbols loaded.

'rotem.exe': Loaded 'C:\WINDOWS\system32\vdmdbg.dll', No symbols loaded.

'rotem.exe': Unloaded 'C:\WINDOWS\system32\vdmdbg.dll'

'rotem.exe': Unloaded 'C:\WINDOWS\system32\psapi.dll'

'rotem.exe': Loaded 'C:\Documents and Settings\Liad\Local Settings\Temp\A5355s._0a', No symbols loaded.

'rotem.exe': Loaded 'C:\WINDOWS\system32\nvoglnt.lrc', No symbols loaded.

First-chance exception at 0x77f69ecd in rotem.exe: 0xC0000005: Access violation writing location 0x00000010.

'rotem.exe': Unloaded 'C:\WINDOWS\system32\nvoglnt.lrc'

'rotem.exe': Unloaded 'C:\Documents and Settings\Liad\Local Settings\Temp\A5355s._0a'

'rotem.exe': Unloaded 'C:\WINDOWS\system32\nvoglnt.dll'

i think it's the nvoglnt files that cause the problem.


i have asus geforce2 gts 64mb on my pc. i would appricate if anyone will help me. my teacher don't know the answer, also i sent an email to asus and i didn't get an answer. please help me

thank you so very much

liad

mikael_aronsson
12-09-2003, 04:21 AM
The program causes an access vilation so there is a problem, don't you have the source code for the application ? if you do, fire it up with a debugger and locate where the problem is.

Mikael

Muhson
12-09-2003, 10:12 PM
thank you for the reply i did the debug the error happens when i am callint the function:

glutCreateWindow("My first window");

this function opens the glut.h file and on the line:

static int APIENTRY glutCreateWindow_ATEXIT_HACK(const char *title) { return __glutCreateWindowWithExit(title, exit); }

a black window is created and after 3 seconds it shut down.

that's what i figure out
can you help??
and thanks

ZbuffeR
12-10-2003, 02:01 PM
I reminds a problem I had with glut progs. I had to do :

#define GLUT_DISABLE_ATEXIT_HACK

in my C file.
Try it out, and tell if it works.

Muhson
12-10-2003, 08:50 PM
ZbuffeR, it doesn't work http://www.opengl.org/discussion_boards/ubb/frown.gif