PDA

View Full Version : Help ! Newbie looking for header file...



GreyPilgrim
06-14-2004, 06:37 AM
First of all, I'd like to apologize for asking such a silly question ; but where the hell can I find header files for OpenGL coding ? (I mean such as glut.h, gl.h, etc...) I run under Win2k pro (french edition), and I use DevCpp for coding (freeware). Thanks to all for having read this, and sorry again for this question.

ZbuffeR
06-14-2004, 09:33 AM
Trop bon, Grenoble ! Les noix et tout !

So here you will find everything you need :
http://opengl.org/resources/faq/getting_started.html

And don't forget to browse to Opengl.org main page, there is a lot of documentation (sometimes a bit hidden).

Bonne chance avec OpenGL !

nexusone
06-14-2004, 11:42 AM
DEV-C++ comes with all the headers needed to compile a openGL program (gl.h, glut.h, glu.h).

The files are located in the DEV-C++ directory under INCLUDE/GL/

You should be able to compile most openGL programs, since DEV-C++ should look in the INCLUDE when it compiles the program code.

Your include files should look like this, which is the standard under compiling openGL under C/C++:

#include <gl/glut.h>;
#include <gl/glu.h>;
#include <gl/gl.h>;


Originally posted by GreyPilgrim:
First of all, I'd like to apologize for asking such a silly question ; but where the hell can I find header files for OpenGL coding ? (I mean such as glut.h, gl.h, etc...) I run under Win2k pro (french edition), and I use DevCpp for coding (freeware). Thanks to all for having read this, and sorry again for this question.

GreyPilgrim
06-15-2004, 08:12 AM
Thanks to all !
Hope I'll get further in gl coding now that I've got all I needed to begin !

GreyPilgrim
06-16-2004, 09:21 AM
Damn ! I just may be really dumb, but I don't know what to do... I've got all the files I needed, but I still get link errors while compiling. Is there something I've forgotten ? Please... help ! (Fifth Element fans, I beg your pardon...)

nexusone
06-16-2004, 01:04 PM
Did you tell DEV-C++ to use the openGL librarys when running the linker?

Look under project options, linker settings and add:

-lopenGL32 -lglu32 -lglut32(if you use glut)


Originally posted by GreyPilgrim:
Damn ! I just may be really dumb, but I don't know what to do... I've got all the files I needed, but I still get link errors while compiling. Is there something I've forgotten ? Please... help ! (Fifth Element fans, I beg your pardon...)