PDA

View Full Version : opengl.dll; uh did i miss something?



quibbles
09-23-2002, 08:51 PM
this is a pretty lame question but... i made a program in c++ using opengl with glut that basically opens a window and displays a square. its out of the red book third edition. this is my first time using glut so ya... but anyway, when i run the program, it errors saying it can't find OPENGL.dll. not opengl32.dll but OPENGL.dll. i tried downloading the opengl files again just to be sure but there is no opengl.dll. nor is there one in glut. does this file even exist? or if you have any other ideas as to what might be wrong, please help.
(oh yeah, my previous opengl programs work, but i didn't use glut for them)

hatemagnet
09-23-2002, 09:26 PM
hi quibbles.

If you are using windows, you need opengl32.
You can get
gl.h, glu.h, glu32.lib, opengl32.lib, glu32.dll, and opengl32.dll from ftp://ftp.microsoft.com/softlib/mslfiles/opengl95.exe. These should already be installed on your system. If they are not, take the header files and install the under the Include/GL directory of Visual C++. Install the library files in the Lib files of Visual C++. Install the .dll's under C:\\WINNT\system32 folder.
The files for glut are located at http://reality.sgi.com/opengl/glut3/glutdlls.zip. You should get glut32.lib, glut.h, and glut32.dll. Install these files in the same locations as you did the OpenGL files. Do not use glut.lib and glut.dll.

I hope that helps.

quibbles
09-24-2002, 05:35 AM
ya, i have all those. other opengl programs work on my computer. just not this one. but thanks for your help.

harsman
09-24-2002, 06:04 AM
Sounds like your linking with opengl.lib instead of opengl32.lib That is an old sgi opengl implementation. Correct your linker settings and you should be fine.

quibbles
09-24-2002, 02:46 PM
no not it either. that was my first thought when i got the error, and i definitly make use opengl32.lib and not opengl.lib. but thanks for your help anyway!

quibbles
09-24-2002, 03:30 PM
i figured it out!!! harsman was on the right track. i was using glut.lib rather than glut32.lib. doh! well, thanks guys for your help!