PDA

View Full Version : why not support opengl1.2 ??



wusheng
10-01-2004, 02:40 AM
My graphics card supports opengl 1.5, and i have installed the driver for the card. But i cannot use the functions that are supported by opengl 1.2,for example: glTexImage3D() and so on...
why?
what should i do?
thanks!

Relic
10-01-2004, 03:46 AM
All functions wich are not supported natively by Microsoft's OpenGL implementation but provided by the graphics driver's installable client driver must be requested with wglGetProcAddress.

You can use some convenient libraries to do that for you.
I use the glh_extensions.h file from NVIDIA's SDK. The beef is in glh_genext.h
Read the comments on top of the glh_extensions.h file carefully. You need to include it exactly once with GLH_EXT_SINGLE_FILE defined (check the SDK examples).

To query extensions and initialize all related function pointer you just call

if (!glh_init_extensions("GL_VERSION_1_5 ARB_whatever_extensions_you_need"))
{
// error, not supported
}