PDA

View Full Version : Dim colors with GL_TEXTURE_2D enabled



JumpMast3r
03-10-2005, 04:49 PM
when i enable GL_TEXTURE_2D my non textured colors (eg. just glVertex3 become very dull and dim.
Any ideas?

shinpaughp
03-10-2005, 05:43 PM
By default every vertex has a texcoord when texturing is enabled even if you haven't set one yet (default is 0,0,0 depending on dimension of texture). You should only enable textures when the texture is actually being used else your objects will be textured with a single color from your texture (blended if blending is enabled, etc).