PDA

View Full Version : again me



08-12-2001, 05:01 PM
sorry, forgot to post the errors:
here they are:

--------------------Configuration: gl - Win32 Debug--------------------
Linking...
gl1.obj : error LNK2001: unresolved external symbol _gluPerspective@32
gl1.obj : error LNK2001: unresolved external symbol __imp__glLoadIdentity@0
gl1.obj : error LNK2001: unresolved external symbol __imp__glMatrixMode@4
gl1.obj : error LNK2001: unresolved external symbol __imp__glViewport@16
gl1.obj : error LNK2001: unresolved external symbol __imp__glHint@8
gl1.obj : error LNK2001: unresolved external symbol __imp__glDepthFunc@4
gl1.obj : error LNK2001: unresolved external symbol __imp__glEnable@4
gl1.obj : error LNK2001: unresolved external symbol __imp__glClearDepth@8
gl1.obj : error LNK2001: unresolved external symbol __imp__glClearColor@16
gl1.obj : error LNK2001: unresolved external symbol __imp__glShadeModel@4
gl1.obj : error LNK2001: unresolved external symbol __imp__glClear@4
gl1.obj : error LNK2001: unresolved external symbol __imp__wglDeleteContext@4
gl1.obj : error LNK2001: unresolved external symbol __imp__wglMakeCurrent@8
gl1.obj : error LNK2001: unresolved external symbol __imp__wglCreateContext@4
Debug/gl.exe : fatal error LNK1120: 14 unresolved externals
Error executing link.exe.

gl.exe - 15 error(s), 0 warning(s)

Kaos
08-12-2001, 06:10 PM
Yep your definatly new. Let me have a guess you couldn't be bothered to read the introduction bit and wanted to get staight down to the coding.... I know i did the same thing to begin with http://www.opengl.org/discussion_boards/ubb/smile.gif. Right what you need to do is goto the Projects menu then the settings option. When the window loads up look for a tab which says 'link' and click on it. At the bottom of this tab there will be a big box containing alot of different named libraries. At the beginning of this list you want to add the following "OpenGL32.lib GLu32.lib GLaux.lib" without the speech marks. Now re-compile your code and bob's your uncle.

08-13-2001, 02:16 PM
THANKS for that help!! i think i am realllly close now.. now i have these 2 errors - can you help again? PLEASE?

Linking...
LIBCD.lib(crt0.obj) : error LNK2001: unresolved external symbol _main
Debug/gl1.exe : fatal error LNK1120: 1 unresolved externals
Error executing link.exe.

gl1.exe - 2 error(s), 0 warning(s)

richardve
08-13-2001, 10:18 PM
Congratulations, you did not read the manual again! http://www.opengl.org/discussion_boards/ubb/wink.gif
(yes, really ALL newbies are having this very same problem because they didn't read everything..)

You've created a console program instead of a win32 program...
(menu File -> New -> win32 application)