PDA

View Full Version : Strange Speed Results



AxelF
05-12-2003, 04:09 AM
Hi,

last weekend i switched from the Direct3D Liga to OpenGL. I really like it..but..

I compiled my tuned Hello World Programm (some nice Stars and an 3DS Object) at home and it ran with 300 Fps on my Radeon 9700. I tested it after this on an old ATI 128..still 30 Fps. Axel was happy!

Today I wanted to check the Performance with the Geforce 2 MX at work. First run: 3 FPS. (2400MhZ Athlon) Wow! Still the same code! Ok, software emulation i thought..
Ok..I updated to Nvidia's reference drivers and now I got 12 FPS. Still a joke..? This cant be all??

I have no idea what went wrong. The initial and render code is from an good tutorial( http://nehe.gamedev.net/). I think its ok. Please..if some of you could take a look at my code..I really need to know why the performance withe the MX is so low. The comments in the source are german, so dont wonder. :-) Here is my Visual C++ 6.0 Project File: www.arses.de/test/axels.zip (http://www.arses.de/test/axels.zip)

I updated the Motherboard drivers..updated to the latest VIA 4in1, tryed a lot of Nvidia drivers. Still the same result. I cant believe the GeForce 2 MX is so bad!

Thanks for all suggestions and comments!

Axel F

Relic
05-12-2003, 08:26 AM
- Try with 24 bits depth buffer.
- Check the renderer (glGetString).
Other perf tips:
- Use the glNormal3fv, glTexCoord2fv and glVertex3fv functions.
- Don't use immediate mode anyway.
- Don't query for color or texture inside the drawing loops, but move the conditions outside.
- Don't bind the same texture over and over again.
- There must be a simpler way to transform the stars.
- Set Clear color to (0,0,0,0), not 0.5 alpha.
- Not sure how big the stars are, but blending isn't the fastest on GeForce MX.
Try adding alpha test to remove fragments which don't contribute to the final color.
- The LoadGLTextures function won't work. Only minification allows mipmapping, magnification not.
- If you specify mipmapping (or keep the default of GL_LINEAR_MIPMAP_NEAREST), you must download mipmaps.
- There's no need to enable and disable GL_LIGHT0 if you enable and disable GL_LIGHTING, too.



[This message has been edited by Relic (edited 05-12-2003).]