PDA

View Full Version : glut.h problem with MS visualC++ "help"



10-20-2001, 04:54 AM
I just purchased MS visual C++ 6.0 and have set up glut as described by the appropriate web sites. When I compile, or build as MS calls it, I get two error relating to linking the glut.h file. "unresolved external symbol___ glutInitWithExit@12" and "unresolved external symbol__glutCreateWindowWithExit@8". I have tried replacing the glut.h file with copies from couple of different online sources, but still come up with this same problem. I had previously been using borland 5.5 with glut, but recently found I cannot add more than one library in the include header of my source code when using borland. I am know up the creek so to speak, as I need to compile for a class project. Any help is greatly appreciated. Jim

dallas
10-20-2001, 08:29 AM
the errors you've received are not with the .h files, but with your linking library -- the glut libs are not included.

to accomplish this, alt+f7 -> Link (tab) -> Object/library modules: type glut32.lib. and more than likely, you'll probably have to enter opengl32.lib, glu32.lib as well to include those libraries as well.

as an aside, at the top left corner of that dialog box is: "Settings for:" which is defaulted to "Win32 debug", you'll want to switch that to "All Configurations", so when you do a release build, those libraries will be included in that too.

dallas
10-20-2001, 08:35 AM
you'll have to include the glut library files

alt+f7 -> link (tab) -> object/library libraries: type glut32.lib

chances are, you'll need to include the opengl and glu libraries as well, so type in opengl32.lib and glu32.lib.

as an aside, at the upper left of that dialog is "Settings for:", change that to "All Configurations" so these libraries are included in release builds.

dallas
10-20-2001, 08:39 AM
sorry about the double post, but the first (i thought) didn't take.

Leyder Dylan
10-20-2001, 10:03 AM
The problem is that you're probably using GLUT 6 and your program need GLUT 7 for being compiled.