PDA

View Full Version : .flt convertion to opengl is through, but model not seen on the viewport



sujudavid
11-18-2004, 11:54 PM
Hi,

I have successfully converted the .flt model to opengl code with the help of Polytrans.I did'nt get any error while compiling also.

But when I call this code inside my program I am not getting this model to be seen on the screen.

any input...

thanks,
Suju.

mikael_aronsson
11-19-2004, 01:30 AM
That would be tricky to answer there are tons of things that could be wrong.

Do you have an active rendering context ?

Have you setup the modelview transformation correct ?

Is the model in a scale and position so it would be visible in your view volume ?

And so on....

Mikael

sujudavid
11-21-2004, 08:53 PM
Hi,

I had taken one of the sample application were I was displaying a big polygon on to whcih I had mapped a ground texture.

This drawing ground was replaced by this converted model of .flt inside the redraw function.When I put this same draw ground function I am able to see the ground, but not the converted model.

The converted code is very big, about 25000 lines, that why I could not post it.

any ideas...mean time i'll try with a small model.

thank you,
S David.

sujudavid
11-24-2004, 01:07 AM
hi,

I have successfully converted the .flt to opengl c code, and could import and view this during the runtime.

But the problem is the textures are not loaded.I have used polytrans to convert the model, but inside this they are not loading the texture, the function is left blank.It looks something like this

//Please replace this routine with one of your //own which will load in the
//requested texture map and make it current //within the OpenGL context.
//If the texture map name is NULL then disable //texture mapping.
void OGL_Set_Current_Texture_Map(char *texture_map_name, float u_scale, float v_scale, float u_offset, float v_offset)
{
}

I am new to opengl so can someone help me filling this function up.

thanks,
Suju.