PDA

View Full Version : error in glu.h



Tarquin13
07-14-2001, 03:04 PM
I swear I saw this topic on the board before, but didn't read it because I was having trouble just setting anything up. I've managed to get Codewarrior to make a Win32 C++ app for the project (I assume that's ok?) and changed the debug settings to include the right system path, and have included gl.h, glu.h and gluax.h in my project. I take the "hello world" program already written as my basis and add #include <gl.h> and all is well, but when I add #include <glu.h> I get an error saying a semi-colon is missin on the line:
const wchar_t* APIENTRY gluErrorUnicodeStringEXT (
GLenum errCode);

in glu.h on line 63. Same thing, line 63 in glu.h when I include glaux, but not glu

any ideas?

(I suppose I don't really know much about the Win32 App files b/c if I try to write something like I would for a console app I get some other winsomthing16 error not matter what's going on, but that's a seperate problem.)

lgrosshennig
07-14-2001, 05:09 PM
You do know that this forum has a search funtion, dont you?

Why dont you give it a try?

lgrosshennig
07-14-2001, 05:10 PM
LOL

That should have been "function"...

Sorry! "Too many fingers on keyboard error..."

Tarquin13
07-15-2001, 04:59 AM
I searched and couldn't seem to find the answer anywhere on the boards. Maybe I saw something about glut.h... anyway, I still have the problem

lgrosshennig
07-15-2001, 05:47 AM
http://www.opengl.org/discussion_boards/ubb/Forum2/HTML/001804.html