PDA

View Full Version : How to get more than 60 fps?



Anonymous Coward
10-15-2000, 12:20 PM
I did a little benchmark to test something I noticed in my program.
I set a blank OGL screen rendering a single quad and I got 63 fps.

How can some people talk about 120-200 fps if a single quad is getting 63 fps?

zed
10-15-2000, 12:59 PM
make your windows smaller http://www.opengl.org/discussion_boards/ubb/smile.gif naw seriously mate it works

Antonio
10-15-2000, 02:26 PM
What graphic card are you using? this may be pertinent to understand your test.

Antonio www.fatech.com/tech (http://www.fatech.com/tech)

drakaza
10-15-2000, 11:07 PM
It also depends what sort of filtering you are using, and what they are using
i.e. LINEAR or CLOSEST or Mipmapped

I wished everyone would benchmark with CLOSEST
as a standard, so that results could be comparable
Ah well http://www.opengl.org/discussion_boards/ubb/frown.gif

zed
10-16-2000, 12:51 AM
u think 63fps is bad , checkout me site under goetterdammerung with one screenshot im cruising along quite nicely at 21fps for 11500 tris and the next thing is i look at me feet and are still only getting 21fps even though now im only draw 88 tris.
theres a moral there somewhere http://members.nbci.com/myBollux/

tdavie
10-16-2000, 12:59 AM
This shouldn't be a problem with using LINEAR or NEAREST texture mapping, I have a game rendering 1000 odd polygons, linear mippmapping, lighting, normalising and blending all on full screen at 1024x768 and it runs fine in excess of 200 fps. Even on my ponsy ATi Rage pro.

Bob
10-16-2000, 01:25 AM
It can be that you have told your card to wait for a vertical retrace before swapping framebuffers. This will, if your program is fast enough, lock your program at the same framerate as you monitor updates the picture. So, if your monitor is set to 60 Hz with vertical retrace wait enabled, you can't get more than 60 fps. Try to toss some more geometry, and see if it keeps the same frametare. If it does, this can be the problem.

My programs never goes above 85 fps, because my monitor keeps a refresh rate of 85 Hz, even if I only toss a single primitive, or several thousands of them each frame.

Anonymous Coward
10-16-2000, 02:27 AM
Well, Im currently rendering 4000 polys at 63 fps, but I tried taking out all geometry, collision detection, textures, keyboard handling, lights, etc. and the 60-65 fps remained. Im using a GeForce 256 with a burned fan so it is giving me some problems sometimes (I need a new card). My app is rendering in a 640x480 window (with a 800x600 resolution).

By the way, I dont know what kind of monitor do I have, is a generic monitor (with Phillips tubes). Where can I see the refresh rate?

Kilam Malik
10-16-2000, 04:51 AM
Another thing which affects your speed is clearing the color buffer. Some games don't need that, because they always draw on every pixel. Quake and Unreal are such games. In some levels you can see strange artifacts, like the pixels from the previous frames are still there. Thats because they don't clear the color buffer, which gives you a few more fps.

Kilam.



[This message has been edited by Kilam Malik (edited 10-16-2000).]

Punchey
10-16-2000, 06:54 AM
Just a request, but if you are going to post a message asking questions or complaining about speed, be so kind as to post some kind of system specs (RAM, CPU, video card, etc.) and some details about your app (resolution, polys, etc.) otherwise, it's hard to be any help whatsoever. Fortunately, in this case it's been narrowed down to the v-sync. But let's all try to keep this in mind in the future. Thanks!

shawge
10-16-2000, 07:00 AM
Since you mentioned that you have a GeForce, you can turn off vertical sync in the opengl settings of your display properties in Windows. My program went from 60 -> 400+ fps by doing this.

Check out the Hercules driver optimization
page: http://us.hercules.com/support/techtips/driver_optimization/opengl.php3

[This message has been edited by shawge (edited 10-16-2000).]

Anonymous Coward
10-16-2000, 10:07 AM
Wow! Now im getting 274 fps!!! Thx guys! That was the problem!