PDA

View Full Version : win2000, geforce4, quake2 a combination from hell



01-14-2003, 12:10 PM
I'm wondering if any opengl gods out there has any ideas to get quake2 to run opengl with windows 2000. To make things worse I have a nvidia geforce4 ti4200 (gainward) card. It would appear that the opengl32.dll file in nt\system32 sucks. Dark screen, low resolution, and slow.

I have seen this before with voodoo3 cards in windows 95 & 98. 3dfx nicely provided drivers to correct the problem. I am not finding anything from nvidia to correct this.
I have fooled with newest nvidia drivers, different opengl32.dll placed in the quake2 dir.I tried openglide. I installed quake2 ver 3.21 hoping for a better gl option.
This appears to clearly be a driver problem.
Any ideas would be most helpfull.

Thanks
jfisher

01-18-2003, 11:56 AM
I've also had problems with Win2k. I know for sure it is the video card/opengl32.dll but there does not seem any current solution. I have one PC with Win2k and a TNT2 card and OGL works just fine. I have another with Win2k and Geforce2 MX 400 and openGL does not work at all. I've installed SP3 and latest Nvidia drivers on both.
When I try to run a OGL application on the Geforce2 PC I get a message box saying "*.exe could not run generating an error log." I don't know what to do, except wait for Nvidia to release some new drivers. *sigh*

OpenGL does work with the GeForce2 card and either WinME or WinXP. I didn't like XP, it's WindowsXP where X=CRA.

01-19-2003, 10:21 AM
Solved my problem. See topic above this one.

01-21-2003, 06:02 AM
Originally posted by jfisher:
I'm wondering if any opengl gods out there has any ideas to get quake2 to run opengl with windows 2000. To make things worse I have a nvidia geforce4 ti4200 (gainward) card. It would appear that the opengl32.dll file in nt\system32 sucks. Dark screen, low resolution, and slow.

I have seen this before with voodoo3 cards in windows 95 & 98. 3dfx nicely provided drivers to correct the problem. I am not finding anything from nvidia to correct this.
I have fooled with newest nvidia drivers, different opengl32.dll placed in the quake2 dir.I tried openglide. I installed quake2 ver 3.21 hoping for a better gl option.
This appears to clearly be a driver problem.
Any ideas would be most helpfull.

Thanks
jfisher

the_klint
01-30-2003, 05:18 AM
I solved my problem (could not play Half life or any other modes of the game in another way than "Sofware-mod" !! so i had no opengl nor direct3d)
my drivers are all up to date (leadtek gforce4 mx440 running on wind2k) i downloaded this file :
nVidia Refresh Rate Fix MKII for Detonator 40.41
(nividia's script modified by a programmer)
at this addresse : http://www.voodoofiles.com/7780
(it helps reshresh rates for geforces cards under windows 2000 and XP)
now half life runs smooth and fine

Features of this file
- Solves 60 Hz bug for DirectDraw, Direct3D and OpenGL
- Lets you specify refresh rates from 60 up to 240.
- Compatible to Detonator 40.41
- Also works with older Detonators, since 28.32

Description
If you have a nVidia graphics card, you'll probably know about the very common bug, that occurs together with the nVidia Detonator drivers under Windows NT/2000/XP: Normally, you can't get a higher refresh rate than 60 Hz in the OpenGL/Direct3D modes, which makes you very blind after a while of gaming. ;-) I programmed this tool, to fix this bug, since I could not find an existing tool for this on the internet, which is compatible with the new official Detonator v28.32 drivers. There already were some tools around that supported the older Detonator versions.


it didn't work for every one (on this forum)i don't know why but ! but the fact is i din't have opengl before hand and after installing this file i could play games with opengl no problem so maybe this can help u
i hope so