PDA

View Full Version : Half-Life, Win XP, and Open GL, TNT2 M64...help me!



03-27-2002, 07:14 PM
Alright. Open GL doesn't work in Half-Life anymore for some reason. I just recently got XP Pro. I have a TNT2 M64 32MB, and I can't run Open GL all of a sudden. I have the detonator drivers for XP from NVIDIA, and I have DX 8. D3d works, but why not Open GL? If someone would be so kind as to answer, it'd be greatly appreciated.

03-28-2002, 02:22 AM
i think the thing is with the Nvidia drivers.
i have the same riva tnt2 m64 ,when i use nvidia drivers nothig works (3d or video), but when i use the window drivers (old ones), every thing works just fine, including openGL.
i hope this will help you, (at least you can try,) menny.

03-28-2002, 07:52 PM
I'll give the old drivers a shot. But before I put the det drivers on, I had the old drivers. nothing worked at all. I'm almost considering going back to 98 if there isn't any known way to fix this annoyance. I've got some LAN parties coming up and I refuse to play Half Life in D3D. Also, Return to Castle Wolfenstein works in Open GL. I've reinstalled Half Life in case there was a corrupt file, however that doesn't work.

devdevlin
04-01-2002, 07:24 PM
i also have tnt2 m64 32mb video card installed in my win98 box, ive installed the drivers that came with the video card, upgraded to directX 8 but still i get very sluggish game play with half-life and counter-strike. how did you go about this problem when you were still using windows98? thank you.


Originally posted by The Amazing Brando:
I'll give the old drivers a shot. But before I put the det drivers on, I had the old drivers. nothing worked at all. I'm almost considering going back to 98 if there isn't any known way to fix this annoyance. I've got some LAN parties coming up and I refuse to play Half Life in D3D. Also, Return to Castle Wolfenstein works in Open GL. I've reinstalled Half Life in case there was a corrupt file, however that doesn't work.

UnkaDonld
04-01-2002, 08:21 PM
You seem in more trouble than most. OK. What's your CPU & M'board -- I need either Pent or AMD & for MB, I need your chipset. If it's VIA & AMD, you got problems. But the fix is simple. You have to do THIS fix before drivers work in XP.

I know. I just did it. So did my nephew, who got my 2 week old "home" ed when I moved up to the XP Pro. db


Originally posted by The Amazing Brando:
Alright. Open GL doesn't work in Half-Life anymore for some reason. I just recently got XP Pro. I have a TNT2 M64 32MB, and I can't run Open GL all of a sudden. I have the detonator drivers for XP from NVIDIA, and I have DX 8. D3d works, but why not Open GL? If someone would be so kind as to answer, it'd be greatly appreciated.

04-02-2002, 04:29 PM
It also seems like a problem specifically with HL, considering that RTCW works for me. This just doesn't make sense. For once CTRL ALT DEL 3 times won't fix it!! ARGH!