PDA

View Full Version : return to castle wolfenstein



12-07-2001, 12:16 PM
i want to run return to castsle wolfenstein on windows xp but i always get this.... and i went to nvidia for downloads but it just wont work,i've donwloaded them al....
rik.roels@yucom.be

Wolf 1.0.0 win-x86 Nov 13 2001
----- FS_Startup -----
Current search path:
C:\PROGRA~1\RETURN~1\main\sp_pak2.pk3 (232 files)
C:\PROGRA~1\RETURN~1\main\sp_pak1.pk3 (1342 files)
C:\PROGRA~1\RETURN~1\main\pak0.pk3 (4775 files)
C:\PROGRA~1\RETURN~1/main

----------------------
6349 files in pk3 files
execing default.cfg
couldn't exec language.cfg
execing wolfconfig.cfg
execing autoexec.cfg
Hunk_Clear: reset the hunk ok
...detecting CPU, found Intel Pentium III
Bypassing CD checks
----- Client Initialization -----
Cmd_AddCommand: map_restart already defined
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\System32\opengl32.dll' ): succeeded
...setting mode 10: 2048 1536 FS
...using colorsbits of 32
...calling CDS: failed, bad mode
...trying next higher resolution: failed, bad mode
...restoring display settings
...registered window class
...created window@3,22 (2054x1574)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 32, 24, 0 )
...50 PFDs found
...hardware acceleration found
...PIXELFORMAT 6 selected
...creating GL context: succeeded
...making context current: succeeded
...WARNING: fullscreen unavailable in this mode
...setting mode 10: 2048 1536 FS
...using colorsbits of 16
...calling CDS: failed, bad mode
...trying next higher resolution: failed, bad mode
...restoring display settings
...window already present, CreateWindowEx skipped
Initializing OpenGL driver
...WARNING: fullscreen unavailable in this mode
...shutting down QGL
...unloading OpenGL DLL
...assuming '3dfxvgl' is a standalone driver
...initializing QGL
...WARNING: missing Glide installation, assuming no 3Dfx available
...shutting down QGL
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
GLW_StartOpenGL() - could not load OpenGL subsystem

12-07-2001, 03:27 PM
i've got an ausu 7700 deluxe (64mb ddr geforce II) and it does the same thing

12-08-2001, 12:27 AM
Originally posted by rik:
i want to run return to castsle wolfenstein on windows xp but i always get this.... and i went to nvidia for downloads but it just wont work,i've donwloaded them al....
rik.roels@yucom.be

Wolf 1.0.0 win-x86 Nov 13 2001
----- FS_Startup -----
Current search path:
C:\PROGRA~1\RETURN~1\main\sp_pak2.pk3 (232 files)
C:\PROGRA~1\RETURN~1\main\sp_pak1.pk3 (1342 files)
C:\PROGRA~1\RETURN~1\main\pak0.pk3 (4775 files)
C:\PROGRA~1\RETURN~1/main

12-11-2001, 11:51 PM
Wolf 1.0.0 win-x86 Nov 13 2001
----- FS_Startup -----
Current search path:
C:\PROGRA~1\RETURN~1\main\sp_pak2.pk3 (232 files)
C:\PROGRA~1\RETURN~1\main\sp_pak1.pk3 (1342 files)
C:\PROGRA~1\RETURN~1\main\pak0.pk3 (4775 files)
C:\PROGRA~1\RETURN~1/main

----------------------
6349 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec wolfconfig.cfg
execing autoexec.cfg
Hunk_Clear: reset the hunk ok
...detecting CPU, found Intel Pentium III
Bypassing CD checks
----- Client Initialization -----
Cmd_AddCommand: map_restart already defined
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINNT\System32\opengl32.dll' ): succeeded
...setting mode 3: 640 480 FS
...using desktop display depth of 32
...calling CDS: ok
...registered window class
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 32, 24, 8 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 32, 24, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...setting mode 3: 640 480 FS
...using colorsbits of 16
...calling CDS: ok
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...shutting down QGL
...unloading OpenGL DLL
...assuming '3dfxvgl' is a standalone driver
...initializing QGL
...WARNING: missing Glide installation, assuming no 3Dfx available
...shutting down QGL
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
GLW_StartOpenGL() - could not load OpenGL subsystem

This is always happens to me too. I don't understand, what are you supposed to do?

12-17-2001, 11:14 PM
Hi there. Try starting RTCW in safe mode. That should work. Then set the video options to 640x400. Then apply the changes, then exit, and start in normal mode.

12-18-2001, 12:51 AM
hi i had the second newest driver for nvidia and it workt with XP but now the newest drivers it does not work can any1 help me find the second newest drivers again

12-18-2001, 02:36 AM
I have win xp and Riva TNT2 graphic card. I got the same problem and dl the new Riva driver.

That got RTCOW working but then the computer startedt to reboot when surfing the net.

I can apparantly choose between a randomly rebooting computer or a working RTCOW.

Klemusch_2002
12-19-2001, 12:11 PM
Originally posted by rik:
i want to run return to castsle wolfenstein on windows xp but i always get this.... and i went to nvidia for downloads but it just wont work,i've donwloaded them al....
rik.roels@yucom.be

Wolf 1.0.0 win-x86 Nov 13 2001
----- FS_Startup -----
Current search path:
C:\PROGRA~1\RETURN~1\main\sp_pak2.pk3 (232 files)
C:\PROGRA~1\RETURN~1\main\sp_pak1.pk3 (1342 files)
C:\PROGRA~1\RETURN~1\main\pak0.pk3 (4775 files)
C:\PROGRA~1\RETURN~1/main

Klemusch_2002
12-19-2001, 12:14 PM
Klemusch_20
Originally posted by rik:
i want to run return to castsle wolfenstein on windows xp but i always get this.... and i went to nvidia for downloads but it just wont work,i've donwloaded them al....
rik.roels@yucom.be

Wolf 1.0.0 win-x86 Nov 13 2001
----- FS_Startup -----
Current search path:
C:\PROGRA~1\RETURN~1\main\sp_pak2.pk3 (232 files)
C:\PROGRA~1\RETURN~1\main\sp_pak1.pk3 (1342 files)
C:\PROGRA~1\RETURN~1\main\pak0.pk3 (4775 files)
C:\PROGRA~1\RETURN~1/main

12-19-2001, 08:39 PM
I had the same problem with Open gl...I fixed it by downloading teh 21.83 drivers at http://www.zdnetindia.com/downloads/drivers/info/62847.html I tried every other xp driver known to man and did not work......but these did good luck

aeshlon
12-20-2001, 01:45 PM
hey--

sorry i'm a moron, but how do you start RtCW in safe mode? do you mean windows safemode? or does the game itself (being run on the q3 engine) have a safe mode?


sorry and thanks!!

aeshlon
12-20-2001, 06:11 PM
Originally posted by jjhann:
Hi there. Try starting RTCW in safe mode. That should work. Then set the video options to 640x400. Then apply the changes, then exit, and start in normal mode.

....did you mean windows safe mode? that didn't work for me...the game won't run

if there's a safe mode for the game let me know


please explain a little bit more so i can play my game again!

thanks much.

12-21-2001, 02:50 AM
hi, i saw the link for return to castle wolfenstein with a windows xp driver but i need one for windows 98 can somebody help? please reply to my message or e-mail me @ remko1@hotmail.com

12-21-2001, 03:06 AM
sorry it was remko15@hotmail.com, i forgot the 5. xxx

ajaxfanrome
12-21-2001, 04:35 AM
Hi all,
Just wanted to let you know how great NVIDIA 21.83 is. Its amazing. I downloaded it from zdnet india very quickly, installed it and now rtcw works fine. Instead of trying safe mode or anything like i suggest downloading the file, its the safest way if you have win xp. For other win systems like win98 you can also go to zdnet india(look at link in prior reply) and download the nvidia file for win 98. RTCW works perfectly now and there are no more problems at all. I really recommend it, forget about safe mode its too much of a hassle. Alex

12-21-2001, 11:57 AM
For everyone who have trouble with opengl
especial with Nvidia cards like TNT 64, download a little program "Gldirect" from http://www.scitechsoft.com/ and it should
work.
good Luck!!

12-21-2001, 11:43 PM
I Have the same problem with my Asus V7700
but with Windows 98...

Can you help me ?
What driver I must use ?

Thanks
fbicio

Drake^
12-23-2001, 06:23 PM
For RTCW safemode goto ur start menu then to programs find the RTCW folder scroll across an u should see it.
I have a Geforce2MX an have had no probs with it bar once when it did what was stated above in the orignal post, i simply rebooted comp went into safemode changed a few settings with my res an bit color an it works fine now.
ON 1 NOTE: I NEVER have any gl game i have above 800x600 res i found this crashes too often for my liking.
Hope this helps http://www.opengl.org/discussion_boards/ubb/smile.gif

[This message has been edited by Drake^ (edited 12-23-2001).]

Dosai
12-26-2001, 09:06 AM
I am using Intel 815E chipset and WIN XP.
RTCW gives the same problem and it does not load the OpenGL sub system.I am not even able to go into safe mode..Pls help.

Dosai
12-26-2001, 09:12 PM
RTCW works fine on XP now that i have loaded the latest drivers 6.xx from intel's support website....But the game is a lil slow

12-26-2001, 10:36 PM
For those with XP and Nvidia drivers that gave you the blue screen,uninstall the current display drivers first.This is a very important step because if you don't,you will get the blue screen. A lot of
people overlook this step(including me).After uninstall,just install the lastest
Nvidia drivers again.