PDA

View Full Version : Creating GL context: Failed - Help!! I cant play Quake 3 anymore!!



03-26-2003, 10:33 PM
For some reason, I cant run Quake 3 Arena on my pc any more. I installed XP onto my system 6 or 7 months ago, and I had some small installation problems, but after reinstalling it was playing fine. A couple of weeks ago, I updated my Nvidia GEForce 2 64Mg 440MMX drivers, and it seems that the problem began then.
Ive tried to search for my exact problem/solution but I cant find it! PLEASE HELP!!
My error message is as below: -

Q3 1.32 win-x86 Oct 7 2002
----- FS_Startup -----
Current search path:
C:\Program Files\Quake III Arena\baseq3\pak8.pk3 (9 files)
C:\Program Files\Quake III Arena\baseq3\pak7.pk3 (4 files)
C:\Program Files\Quake III Arena\baseq3\pak6.pk3 (64 files)
C:\Program Files\Quake III Arena\baseq3\pak5.pk3 (7 files)
C:\Program Files\Quake III Arena\baseq3\pak4.pk3 (272 files)
C:\Program Files\Quake III Arena\baseq3\pak3.pk3 (4 files)
C:\Program Files\Quake III Arena\baseq3\pak2.pk3 (148 files)
C:\Program Files\Quake III Arena\baseq3\pak1.pk3 (26 files)
C:\Program Files\Quake III Arena\baseq3\pak0.pk3 (3539 files)
C:\Program Files\Quake III Arena/baseq3

----------------------
4073 files in pk3 files
execing default.cfg
execing q3config.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
...detecting CPU, found Intel Pentium III

------- Input Initialization -------
No window for DirectInput mouse init, delaying
Joystick is not active.
------------------------------------
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\System32\opengl32.dll' ): succeeded
...setting mode 3: 640 480 FS
...using desktop display depth of 32
...calling CDS: ok
...registered window class
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 32, 24, 8 )
...0 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 32, 24, 0 )
...0 PFDs found
...MCD acceleration found
...PIXELFORMAT 1 selected
...creating GL context: failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...setting mode 3: 640 480 FS
...using colorsbits of 16
...calling CDS: ok
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
----- CL_Shutdown -----
RE_Shutdown( 1 )
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): failed
...releasing DC: success
...destroying window
...resetting display
...shutting down QGL
...unloading OpenGL DLL
-----------------------
Q_strncpyz: NULL src