PDA

View Full Version : OPEN GL EXTRA HELP AND FIXES



10-07-2003, 02:24 PM
posted 10-07-2003 04:16 PM
-------------------------------------------------------------------------------- http://groups.msn.com/OpenGlProblems/documents.msnw The opengl32.ddl is a fix u download it from documents and overite ur other c:/windows/system32and it should play open gl games.
*Link to this page for pro help, it will explain all! http://groups.msn.com/OpenGlProblems/links.msnw
First for chips, start, control pannel, system then hardware, then device manager look under display adapters,, write down the name and maker of ur card. go on the web and search the maker then download the update fo, exe i have a radeon 7000 made by ati TECHNOLIGIES). , go to www.ati.com (http://www.ati.com) , look under find driver / download drivers, find ur driver and instal, then adjust ur settings and try ur game........ should work..
...REMEMBER IF UR CARD IS MADE BY A COMPANY U MUST UPDATE IT AT THAT COMPANY IF U DONT IT WONT EVEN WORK.
NOW moniters, start, control pannel, system then hardware, then device manager, look under moniters and see how many are installed, if you have two installed click one one and disable it. (that is how to fix, but not the problem on my computer, my computer has a plug and play moniter because xp installs stuff itself)
hey ppl if u really want to see if your card is at fault of not being able to play go to activisions website (maker of theeses 3d games) and send them ur dxaig test. start,run,type in :dxaig.exe,press save,attach that file in the acitvision support question they r really helpfull.,www.activision.com press support, or just go to links on this site and there is a direct link.
*for non xp*Click Start / Run.
Type "win.ini" (without quotes) and press OK.
Search for a line that says "DVA=0" (without the quotes).
Add a semicolon ( before the DVA (the line should now look like this: ";DVA=0" (without quotes))
Save and close the file
If you find this causes more problems, just take out the semicolon.
all ..Check to make sure you have a supported 3D video card to play the game. Return to Castle Wolfenstein requires that you have one of the supported 3D cards to play the game. Your card must have 100% OpenGL support and at least 16 MB of memory. A list of the supported chipset is listed in the minimum system requirements.Make sure you have the latest video and sound card drivers from the manufacturers' websites.
If you have a motherboard with an onboard video card you need to disable it in the system BIOS. Refer to your motherboard manual and/or contact your motherboard manufacturer on how to do this.
If you are using a video card which supports dual monitors, the secondary monitor must be disabled for OpenGL to initialize correctly.
Make sure the 3D hardware acceleration is turned all the way up.
1) Right-click on the My Computer icon on the desktop and select Properties.
2) Select the Performance tab and click the Graphics button.
3) Make sure the acceleration slider is set to Full.
For Windows XP and 2000:
1) Click on the Start button > Settings > Control Panel.
2) Double-click the Display icon.
3) Click the Settings tab.
4) Click the Advanced button.
5) Click the Troubleshoot tab.
6) Make sure the acceleration slider is set to Full..
Set your virtual memory to a fixed size.
1) Right-click on My Computer and select Properties.
2) Click the Advanced button, click on Performance settings.
3) Click the Advanced tab, click the Change button.
4) Set the Virtual Memory to a minimum and maximum size of 600MB.
5) Confirm your selections until at the desktop - you may need to reboot.

NOTE: These steps are specific to Windows XP, Windows NT and 2000 may differ slightly.
This will occur when insufficient Virtual Memory is available for the game. For the best performance and stability under Windows NT, 2000 and XP you should aim for having at least 600MB of virtual memory available.
Turn off GL Extensions in the game by changing the configuration file.
1) Click the Start button > Programs > Accessories > Wordpad.
2) Open the wolfconfig.cfg file which is located in the Return to Castle Wolfenstein\Main directory on your machine.
3) Locate the line reading:
seta r_allowExtensions "1"
4) Change the 1 to a 0.
5) Click File > Save.

If you are not using a 3Dfx video card, disable the WickedGL support in the game.
1) Click the Start button > Programs > Accessories > Wordpad.
2) Open the WOLFCONFIG.CFG file located in the C:\...\Return to Castle Wolfenstein\Main directory.
3) Located a line reading:
seta r_glIgnoreWicked3D "0"
4) Change the "0" to a "1".
5) Save the file.
It is possible the game is having issues generating the configuration file on it's first run. Try downloading and installing the wolfconfig.cfg file listed below to the game's \MAIN directory.

If you are using a 3Dfx video card try copying the custom 3dfx OpenGL files into the System directory.
1) Use My Computer to navigate to the Return to Castle Wolfenstein drive on your hard drive.
2) Double-click the GL folder
3) Click Edit then Select All.
4) Click Edit then Copy.
5) Again using My Computer, go to the C:\WINDOWS\SYSTEM* folder.
6) Click Edit, then paste. Do not overwrite any existing files.
* This directory name will change depending on what version of Windows you have.
Windows 95,98,ME: - C:\WINDOWS\SYSTEM
Windows 2000, NT: - C:\WINNT\SYSTEM32

Windows XP Users:
Please note that the default drivers that come with Windows XP are NOT OpenGL compatible. You will need to go to the video card or video chip manufacturer and obtain the latest Windows XP compatible drivers with OpenGL support. This is especially true for ATi and nVidia based video cards.
*enemy territory**
Make sure you have the latest video and sound card drivers from the manufacturers' websites.
Set your desktop to a resolution of 800x600, 32 bit True Color.
1) Right-click on your desktop and select Properties.
2) Click the Settings tab.
3) Set your screen area to 800x600.
4) Set the colors to 32 Bit (True Color). Under Windows NT this will be listed as 65554 colors.
5) Click Apply and OK.
All background applications must be shutdown prior to running the game.

Make sure the 3D hardware acceleration is turned all the way up.
1) Right-click on the My Computer icon on the desktop and select Properties.
2) Select the Performance tab and click the Graphics button.
3) Make sure the acceleration slider is set to Full.

For Windows XP and 2000:
1) Click on the Start button > Settings > Control Panel.
2) Double-click the Display icon.
3) Click the Settings tab.
4) Click the Advanced button.
5) Click the Troubleshoot tab.
6) Make sure the acceleration slider is set to Full.

10-07-2003, 03:52 PM
I have a p2 500mhz and a Matrox G200.

When i try to play to Quake3 Arena this message appear ''Could not load OpenGL subsystem''... I have tried to change de ''DVA=0'' file to '';DVA=0'' but i didnt find it... Whereee is the file DVA!!!! I am on win 98

10-07-2003, 04:51 PM
Originally posted by Mister1:
I have a p2 500mhz and a Matrox G200.

When i try to play to Quake3 Arena this message appear ''Could not load OpenGL subsystem''... I have tried to change de ''DVA=0'' file to '';DVA=0'' but i didnt find it... Whereee is the file DVA!!!! I am on win 98

ok, if you are running 98 :
*for non xp*.Click Start / Run.
Type "win.ini" (without quotes) and press OK.
Search for a line that says "DVA=0" (without the quotes).
Add a semicolon ( http://www.opengl.org/discussion_boards/ubb/wink.gif before the DVA (the line should now look like this: ";DVA=0" (without quotes))
Save and close the file
If you find this causes more problems, just take out the semicolon.

if you already tried that and it did not work try other things/ ideas at http://groups.msn.com/openglprobelms