PDA

View Full Version : Open gl support for Annihilator 2



11-15-2000, 10:32 PM
I'm runnin a 32MB Annihilator 2 (AGP) in a DELL dimension 333. I get the opengl subsystem error when loading q3. I have tried drivers off the CD, creative labs, 3d blaster, nvidia reference drivers, glsetup and still no working gl driver. I just upgraded from a Voodoo2 accelerator. Please advise.

11-16-2000, 12:05 AM
Hi check this out first!

Click Start / Run.
Type "win.ini" (without quotes) and press OK.
Search for a line that says "DVA=0" (without quotes).
Add a semicolon ( before the DVA (The line should now look like this: ";DVA=0" (without quotes))
Save and close the file
If you find this causes more problems, just take out the semicolon.
Note that not everyone has this line, and if there is none you'll have to try another solution.

11-16-2000, 07:34 AM
Unfortunately I do not have this line in my "win.ini" file. Thanks though.

11-16-2000, 09:34 PM
Which mobo and OS do you got!

11-17-2000, 08:11 AM
Intel motherboard PII 333 on W98.

11-17-2000, 02:10 PM
When you do the openGL setup youve been asked to force your driver over those that already is installed, do so

11-17-2000, 02:38 PM
I tried that too. Same opengl error.

11-18-2000, 06:04 PM
Does your direct 3D working good?

11-20-2000, 08:46 AM
Problem resolved. Blew away system and installed ME. Problem was conflicting drivers in registry. Doing regular unistalls just doesn't work. With clean registry and new Nvidia drivers (Detonator 3)the card performs well http://www.opengl.org/discussion_boards/ubb/smile.gif

11-20-2000, 11:41 AM
Great you get it going.
It looks like Creative is very sensitive about drivers. Here is a formula if it happen again.

Here it is:
- Run any uninstall from Add/Remove Programs for the drivers. These frequently are
not totally thorough but should be done anyway.

After you reboot, delete these files
In C:\Windows\System: nv*.*, bc*.*, bls*.*, 3dbg*.*
(the latter 3 only apply to Creative drivers)

In C:\Wwindows\Inf: drvdata.bin, drvidx.bin, 3dbg*.inf, nv*.inf

In C:\Inf\Other: 3dbg*.inf, nv*.inf

HKEY_LOCAL_MACHINE\SOFTWARE\Creative Tech\Blaster Control 3.0

HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Controls
Folder\Device\shellex\PropertySheetHandlers\Blaste r Control 3.0

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Controls
Folder\Device\shellex\PropertySheetHandlers\NVTwea k
(look under Controls Folder\Display as well as Device keys here for
Blaster Control or NVTweak keys)

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Run
- look for bcdetect or NVInitialize entries on the right side and
delete them but not the whole Run key. Also, check the RunOnce
key for the same entries.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\OpenGLdrivers
- delete the RIVATNT entry on the right side


After you have done this do a reinstall of windows(not format).

Then install the drivers to your garaphiccard.

Donít install any open GL drivers separately.

Hope you dont need it.