PDA

View Full Version : Counter Strike / opengl



Killah
07-12-2003, 10:26 AM
When I go and try to play counter strike in opengl it says "Your video card does not support opengl". I'm using a "Bloody Monster Geforce4 family PCI video card and i'm running windows 98. I've gone to windows/system and if looked for opengl32.dll and I couldn't find that. Any feedback would be nice, Thanks.

[This message has been edited by Killah (edited 07-12-2003).]

al_bob
07-12-2003, 10:55 AM
opengl32.dll should come with Windows - you may need to reinstall, or find that file from another Win98 installation.

mrpogi23
07-12-2003, 09:18 PM
i think its on system32 folder, i have the same problem and i have that opengl file on there and still not working. Also that nvidia client opengl driver probably have problem (nvopgl.dll?)
Its been weeks now and i still haven't found the solution to this. Since Nvidia don't have support for these problems, we're stuck.

V-man
07-13-2003, 06:33 AM
What have you done so far?

Installed the new drivers?
Setup your screen?
etc etc...

A Fire Inside
07-16-2003, 03:52 PM
Killah, I'm in the same exact position you are, along with the same game (counter-strike). Only I have the GeForce 2 MX 200.

Ill be honest, i use to hack in counter-strike, and about two months ago, I decided to clean up my game, and be fair to everyone else, so i was going to delete my hack. The hack I had worked along OpenGL's files.

While i was deleting it, i had to manually delete some files, and i accidentally deleted the opengl.dll file from my computer without knowing.

Since then, ive done everything to get opengl mode back for counter-strike, but I cant seem to figure it out.

Ive re-installed my video card files multiple times with no progress. So i know the problem is further then just my video card.

If anyone has any suggestions, or knows the anwser on how to get my opengl.dll file back, please post back. You would be doing me a huge favor.

A Fire Inside
07-16-2003, 03:54 PM
Killah, I'm in the same exact position you are, along with the same game (counter-strike). Only I have the GeForce 2 MX 200.

Ill be honest, i use to hack in counter-strike, and about two months ago, I decided to clean up my game, and be fair to everyone else, so i was going to delete my hack. The hack I had worked along OpenGL's files.

While i was deleting it, i had to manually delete some files, and i accidentally deleted the opengl.dll file from my computer without knowing.

Since then, ive done everything to get opengl mode back for counter-strike, but I cant seem to figure it out.

Ive re-installed my video card files multiple times with no progress. So i know the problem is further then just my video card.

If anyone has any suggestions, or knows the anwser on how to get my opengl.dll file back, please post back. You would be doing me a huge favor.

A Fire Inside
07-16-2003, 04:02 PM
Ahhh, Sorry for the double post people.

07-20-2003, 06:47 AM
Well as for the original poster Ive got the same problem and anytime I want to play counter strike I just slap the old voodoo 3 in and play all night then switch cards in the morning.

As for the Fire Inside guy. GOOD! I hate motherfuhckers like you cheatin in CS and Half Life. I dont care if you are "reformed". Once a cheater always a cheater. I hope you NEVER fix your shiet lamer. LOL!

Dont take that personal dude I just hate skilless little kiddie noobs like you that think your soooo bad ass with your hax. Thats what you get oleeeeee busta biatch ass.

07-23-2003, 06:44 AM
3 ways to get OpenGL :
======================

-> from C:\WINDOWS\SYSTEM where it is named OPENGL32.DLL which is the OpenGL Client DLL v 4.00 provided within Win 9x (others version read below)

-> from the OpenGL site http://www.opengl.org/users/downloads/index.html

-> from the game itself


Then COPY the OPENGL32.DLL file into :
======================================
HALF LIFE RETAIL VERSION
------------------------
<HDD>:\Sierra\Half-Life\gldrv
COUNTER STRIKE RETAIL VERSION
-----------------------------
<HDD>:\Sierra\Counter-Strike\gldrv


AND SO ON FOR EACH MOD !


Last edit each file named "drvmap.txt" and add the following line :
================================================== ================
gldrv/OPENGL32.DLL OpenGL Driver v 4.0 for Win NT

This can be done by copying+pasting the above line.

If you can get a different version of this OPENGL32.DLL you should place it into the WINDOWS\SYSTEM folder ONLY AFTER you've renamed the original file like this "Original OPENGL32.DLL"

Have fun http://www.opengl.org/discussion_boards/ubb/wink.gif

07-23-2003, 06:55 AM
OUPS ! I've forgot this http://www.opengl.org/discussion_boards/ubb/biggrin.gif

FINAL STEP
==========

1) From within the game MENU go to CONFIGURATION -> GRAPHICS -> GRAPHIC MODES.

2) clic on the tiny TRIANGLE above CANCEL then from within the pop-up select "OpenGL Driver v 4.0 for Win NT"

3) select the SAME RESOLUTION AS YOUR desktop's !
( where's the color depth selector ? GASP !)

4) click on OK then APPLY then APPLY again

5) Have fun http://www.opengl.org/discussion_boards/ubb/wink.gif

07-23-2003, 07:31 AM
MANY OTHER TECHNICAL ISSUES THERE => http://techsupport.vuinteractive.com/techsupport/sierra/support.asp

http://www.opengl.org/discussion_boards/ubb/wink.gif

08-01-2003, 11:51 AM
Max Le Fou :
"2) clic on the tiny TRIANGLE above CANCEL then from within the pop-up select "OpenGL Driver v 4.0 for Win NT""
================================================== ====
I don't see that.

08-08-2003, 05:08 PM
im having the same problem as all of u exept i have a geforce fx 5200 wtf is wrong with geforce, **** everyone is having ****ing problems, wtf is going on and wut is nvidia gonna do about this

08-09-2003, 12:41 PM
well i think the nvidia guys are having anal sex with eachother. wich is probably why they cant be arsed to sort out the problem at hand.

TER[]v[](o)[]-[]NATOR
08-11-2003, 01:16 AM
A'right lads, long post, but pleeeease bear with me http://www.opengl.org/discussion_boards/ubb/smile.gif

I've got a similar problem to the original poster

Ok.... first the system spec

Windows 98SE, Pentium 2 350Mhz, 400MB PC100 System RAM, BX Superchips Motherboard, 40 GIG Maxtor 7200RPM HDD and a 32MB Innovision TNT2 RIVA PCI.

My problem is that Counterstrike has a really bad frame rate
(are we seeing a pattern here ?? http://www.opengl.org/discussion_boards/ubb/tongue.gif)

RUNS AT A MEASLY 15-20 fps???? :eek:

This is at 640X480 16 bit color Opengl (or directx 9 for that matter)

wtf is going on?

The system is setup with a dual profile, with the other profile holding the driver info for an Intel Extreme chipset, could this be my problem?

I've got the latest nvidia drivers, the latest opengl installed, directx 9, and i've replaced the original 3dfxgl.dll in the opengl directory in halflife dir with the newest opengl.dll file from the nvidia driver...and still 15-20 fps (Im going insane, sum1 help me as I know my sys is capable of at least 50 fps (i would think)

Any replies would be most appreciated

Ta

Paul.

08-11-2003, 02:35 AM
im sorry but ur a fool if u think ur system can do more than the 15-20fps ur getting let-alone 50fps... ive got the same setup cept with a 600mhz celly and im getting 20-40fps in win98... cant get the bloody thing to work in win2003 tho http://www.opengl.org/discussion_boards/ubb/frown.gif

08-11-2003, 04:14 AM
Originally posted by jdgordon:
im sorry but ur a fool if u think ur system can do more than the 15-20fps ur getting let-alone 50fps...

I agree. One should not expect great framerates with a computer that was outdated years ago.

A Pentium 2 350Mhz! I have more powerful CPUs sitting on my desk collecting dust.

It will be interesting to see the complaints about low framerates when CS2 comes out.

08-11-2003, 08:14 AM
i have "same" problems altough. i've gforce fx 5600 128mb n when i try 2 play with CS in opengl mode , the game when loads literally FREEZE n i have 2 reboot my pc. only in half life / cs i have this prob , the other games using opengl dont make any troubleshooting. my SO is winXP n i have the last diretx 9.0b n the lastest whql drivers 45.23 ...playing cs with direct3d @ 50 fps unstables is annoying =_= any sol?

08-22-2003, 07:40 PM
not so much a new topic but i know i have open gl on my computer and i just purchase the new radeon 9800 pro 256mb and i can not run cs with open gl... same error messsage so what gives..?

10-14-2003, 04:08 PM
I have a radeon 9800 with athlonxp and i used to be able to play counterstrike fine with geforce 4 ti 4200. Ever since i had my 9800 all i get is choke and lag, anyone know why. I tried newest drivers, oldest drivers, reformatting, everything. Is there something i didn't do that anyone knows about thank you http://www.opengl.org/discussion_boards/ubb/smile.gif

10-14-2003, 06:12 PM
Originally posted by A Fire Inside:
Killah, I'm in the same exact position you are, along with the same game (counter-strike). Only I have the GeForce 2 MX 200.

Ill be honest, i use to hack in counter-strike, and about two months ago, I decided to clean up my game, and be fair to everyone else, so i was going to delete my hack. The hack I had worked along OpenGL's files.

While i was deleting it, i had to manually delete some files, and i accidentally deleted the opengl.dll file from my computer without knowing.

Since then, ive done everything to get opengl mode back for counter-strike, but I cant seem to figure it out.

Ive re-installed my video card files multiple times with no progress. So i know the problem is further then just my video card.

If anyone has any suggestions, or knows the anwser on how to get my opengl.dll file back, please post back. You would be doing me a huge favor.

MUUUHHHAHAHAHAHAAAA, you are BUSTED.

Suits you right, you cant escape JUSTICE.

10-21-2003, 10:47 AM
***THIS WORKED FOR ME***

A friend of mine reinstalled windows cause he thought his opengl was screwed up... all in vain. In fact, MATLAB was running in the backround and for some reason would not allow opengl to work. So the answer to my problems was simply ctrl+alt+delete. After it worked I was so pumped I almost kicked my mom in the face.

sa133
10-21-2003, 03:34 PM
God damn it, I never thought about that. Matlab was running a server on mine too.
I'm ready to kick your mom in the face too!