PDA

View Full Version : Same Sh*t Different Day OPENGHELL



07-21-2003, 06:58 AM
Just thought id try to help while getting some help myself.

There has to be something we have all overlooked, some technique or something.

From the looks of it Nvidia, Sierra and Microsoft could care less if we get this fixed or not as they already have their money.

Heres my problem. Every other application I have will use open gl EXCEPT Half Life and its mods. This makes me think its half life specific even though Im told its not always the case.

Im a voodoo man by trade so to speak. Ive made voodoo cards work in open GL on the crappiest systems. However I no longer use the card as I want a faster one.

This may help us. The other day I installed HAlf Life Uplink demo. IT ran flawless in d3d but still couldnt get it to run in gl. I went and installed scietech gl drivers adn then Open GL worked for the Demo only. Hmmmmm

I have tried everything and everything is clean installed on here. The best ive gotten it to run is this:
I select opengl as my display mode in Half Life i choose a game attempt to join...
I get the "Loading" screen and it makes me think its about to work as the screen changes. Then it goes back to the infamous error.

Now keep in mind i still have Sci Tech GL on the machin. I look closesly at the display modes. Even though 640 x 480 is listedits NOT listed as a setting in my windows monitor settings.

Could an improperly "installed" monitor affect such an old game like Half Life. Remember half life even though updated is an old program. Not much has changed since 97 give or take a code or two.

Could this also be a reason why it has problems with newer hardware AND OS's that it never was programed for?

Sorry for the long ass article guys but ive been trying for almost a month and a half to get my Nvidia card to run half life in open gl.

I DO know this. OpenGL 95 sucked. Not only did it not fix my problem it made my other apps openGL not work either so i reinstalled XP. I wouldnt suggest "ADDING" extra things like this or replacing critical files.

I did notice while browsing my system folders that nvoglnt.dll is the Nividia Open GL driver.

If you use an Nvidia Card with the 44.03 drivers look in this folder

C:\WINDOWS\system32\NvInst

Theres a file in there called nvopengl.dll which is NOT listed in your Cards drivers when you open your display properties.

Now by the name that implies its ALSO a GL driver. However I couldnt get it to work with the gldrv/nvopengl.dll/<name> trick
Theres an easy method of fixin it I FEEL it. I just dont have the experience to get it....yet.

I will try to help everyone whos havin this damn problem if I fix mine. In the meantime good luck all.