PDA

View Full Version : Counter Strike, Opengl and Geforce2 MX



Khlabeb
07-03-2001, 03:30 AM
I'm having a problem with OpenGL. When I run Counter Strike, and already in a game, I get 30-60 fps better than Direct3D which is 20-50 fps. So I'd wish to run on OpenGL, but when I do, a few minutes into the game the when I change weapons. The game freezes, so anything I try to do to get out of the game won't work, expect rebooting the computer http://www.opengl.org/discussion_boards/ubb/frown.gif. I'd like to run in OpenGL because of the game freezes up and I hear the sound of what I last did repeating. It usually happens higher fps. I've downloaded all the latest drivers, but the drivers do not show on the list of drivers, so I run OpenGL and Direct3D on default drivers. That's also a problem I'd like to solve http://www.opengl.org/discussion_boards/ubb/smile.gif. But right now im Stuck on Direct3D, could anyone help?

Also my fps is low for a Geforce2 MX, cuz I have a P2 266 http://www.opengl.org/discussion_boards/ubb/smile.gif

My system:

P2 266Mhz
196Mb of pc1433 RAM
3D Prophet II MX (Geforce 2 MX)
Windows 98



[This message has been edited by Khlabeb (edited 07-03-2001).]

Rob The Bloke
07-09-2001, 04:14 PM
The reasons I've seen so far for this are as follows:

1. The card was one of the first batch and very unstable - solution get a refund.

2. The sytem was overclocked, dropping the processor speed back down allowed it to run stable.

In most cases I've seen, people tended to chuck them and buy GTS's

07-10-2001, 08:54 AM
I've been having the same problem. Every time I start either Quake3 or Black & White, I get an error at nvopengl.dll. The game proceeds to shut off leaving the sound going. I am running GeForce2 GTS on a P3 1GHZ. Please help, im really stuck man. By the way, Ive already downloaded all the new drivers and stuff so thats not it. Thanks.

07-15-2001, 10:06 AM
Yes, this sounds horribly familiar :-( exactly the same thing has been happening to me when playing Counter Strike (CS) or Baldur's Gate (BG) in openGL... A sound (such as the changing of a weapon magazine, footsteps etc) seems to initiate my computer to lock-up. CS runs without crashing when I use Direct3d, I don't think I can run BG in direct3d so haven't tried.

My system
K7M mobo w/ 600mhz Athlon (clasic)w/300W power supply (all approriate drivers installed)
ASUS GeForce2 GTS 32 (currently using ASUS Drivers v5.16d, I have tried many others including Nvidia latest so plz don't suggest them)
Sound Blaster live (value)
384MB RAM
Win 98SE

I haven't installed the latest Beta Drivers for openGL yet, though I am about to. Failing that I plan on switching my sound card to see if that has anything to with my problems.

Sorry Khlabeb & Johnnny, nothing to suggest, but should I fix my problem which sounds alot like your own I will post how here..
just don't hold your breath waiting ;-)

07-17-2001, 10:27 AM
Well I tried the latest beta drivers for openGL and they were no help at all. However, I switched my SoundBlaster live value card to a Diamond Monster Card and I can no play CS in openGL no problem. I can also play BG2 now, but not with the 3D effects (it crashes if I use them). So, obviously there are some things still to be fixed..

So, I'm guessing there may be some compatibility issues with older (I bought my card 2 years ago) Soundblaster live value cards and GeForce2 cards.. Could this be your problem as well?