PDA

View Full Version : Starwars Nights Of the Old Republic



06-04-2005, 01:31 PM
I am trying to play Starwars Nights of the old Republic from Lucas Arts, but I'm told by the programme "required non-windows generic open GL 1.4.0 drivers"
I have an S3 graphics ProSavage DDR 128.
I have unsuccesfully tried to find this type of driver please help me - bearing in mind that I'm not that great with this type of thing so please keep it relatively simple

06-04-2005, 01:53 PM
I keep it as simple as possible:

Sorry but forget it, your integrated 3d solution doesnt cut it.

06-04-2005, 08:25 PM
How old is this card?
Can you run GLinfo http://www.delphi3d.net/hardware/index.php
and post what it says onthe first page.

06-04-2005, 10:53 PM
Deguy

This is what the first page says

Driver version Unknown
Vendor S3 Graphics, Incorporated
Renderer ProSavage/Twister
OpenGL version 1.1 2.40.116

did you see the previous post by qwerty77 says I need to get a new graphics card

06-05-2005, 12:53 AM
Yes! The problem is that your integrated 3d solution:

a.) dosent have the featured required by KOTOR
b.) is way to slow to deliver playable framerates in KOTOR
c.) The S3 drivers have a long history of been crap

Its good enough for old games but any newer game will cause problems.

Just to give you an idea how your chip stacks up against other cards. You will get around 100 million pixels per second out of your S3 thing, under the same condition even a crapy Geforce2 pumps out at least 1 billion pixels not to mention that the Geforce2 already features hardware transform and ligntning so that the triangle throughput will be at least three fold.

The problem is that even a Geforce2 is way to slow to deliver playabe framerates in KOTOR you need at least a Geforce3/4 TI/FX or an ATI Radeon 9500++ to really enjoy the eye candy.

06-05-2005, 09:46 AM
I have the same problem with OpenGL

I've done the GLinfo
here the results:

Driver version: 6.14.1.3100
Vendor: SiS
Renderer: Xabre VGA / MMX / SSE2 / AGP
OpenGL version: 1.3.0

Do I have any hope to get OpenGL 1.4.0 ????

ZbuffeR
06-05-2005, 11:44 AM
Originally posted by <TC>:
Vendor: SiS
Renderer: Xabre VGA / MMX / SSE2 / AGP
OpenGL version: 1.3.0

Do I have any hope to get OpenGL 1.4.0 ????Just ask Sis ...

06-05-2005, 12:12 PM
there is another option??
SiS don't do this kind of job

=/

06-05-2005, 12:31 PM
Its SiS job to write the driver, if they dont do it you are out of luck.

The games that require 1.4 need a lot of power anyway so would you be happier if the gameplay crawls at 10 FPS at 640x480 with minimum details?

If you want to play mainstream games you need a mainstream 3d card, it wont get any simpler then that.

If you are unhappy with that, get yourself a console like the XBox(1 or 2) or Playstation (2 or 3).

06-05-2005, 12:39 PM
qwerty77

Thanks for the advice - off to the shops for the upgrade I guess.

06-05-2005, 12:46 PM
You are welcome.

For OpenGL based games I personaly prefer Nvidia cards, I still find that ATI's OpenGL support is somewhat lacking.