PDA

View Full Version : SIS300/305+XP+Jedi Knight 2



04-20-2002, 09:21 PM
when i try to play jedi knight 2 it says that the opengl subsystem is not supported. i cant find the latest driver for it but i have already checked with SIS and they said SIS300/305 does work with opengl.