PDA

View Full Version : OPEN GL AND QUAKE 3 PROB. PLEASE HELPP!!!!



06-25-2001, 08:19 AM
ok 1st of all my comp sais low desktop display depth or something like that. then it sais: GLW_StartOpenGL() - could not load OpenGl subsystem.

heres the rest of the window (from the beginning:

Q3 1.11 win-x86 Nov 29 1999
----- FS_Startup -----
Current search path:
C:\Q3Ademo/baseq3

----------------------

Running in restricted demo mode.

----- FS_Startup -----
Current search path:
C:\Q3Ademo\demoq3\pak0.pk3 (1387 files)
C:\Q3Ademo/demoq3

----------------------
execing default.cfg
execing q3config.cfg
couldn't exec autoexec.cfg
...detecting CPU, found x86 (P5/Pentium2, MMX)

------- Input Initialization -------
Initializing DirectInput...
Couldn't set DI coop level
Falling back to Win32 mouse support...
Joystick is not active.
------------------------------------
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
--- Common Initialization Complete ---
Winsock Initialized
Opening IP socket: localhost:27960
Hostname: pavilion
IP: 172.183.60.45
Working directory: C:\Q3Ademo
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\SYSTEM\opengl32.dll' ): succeeded
...setting mode 3: 640 480 FS
...using desktop display depth of 24
...calling CDS: ok
...registered window class
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 24, 24, 8 )
...23 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 24, 24, 0 )
...23 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...setting mode 3: 640 480 FS
...using colorsbits of 16
...calling CDS: ok
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...23 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 16, 16, 0 )
...23 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...shutting down QGL
...unloading OpenGL DLL
...assuming '3dfxvgl' is a standalone driver
...initializing QGL
...WARNING: missing Glide installation, assuming no 3Dfx available
...shutting down QGL
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
GLW_StartOpenGL() - could not load OpenGL subsystem

06-25-2001, 10:45 PM
It has been many posts on this topic in this forum. You can search for them.