PDA

View Full Version : Chronicles of Riddick



08-18-2005, 01:01 PM
I recently bought Chronicles of Riddick, but I can't get the game to run. It says I need at least OpenGL 1.3. I have a GeForce 6600 GT and I installed all the latest drivers. Can someone help me with this? Thanks.

08-20-2005, 10:12 AM
got that problem too, only difference is that it used to work for me.
still working on it

08-20-2005, 02:36 PM
I managed to solve my problem. Graphics card drivers wasn't actually the problem here. I didn't realise there was a patch for the game. I downloaded and installed it and now the game works fine.

Patch can be downloaded from:
http://www.3dgamers.com/games/chroniclesriddick/downloads/

08-21-2005, 12:23 PM
kuwl, it works thx