PDA

View Full Version : ATI Radeon 7500 not working with OpenGL



GinnaiDoma
01-04-2002, 10:52 AM
I'm trying to use OpenGL for Half-Life. I just got this Radeon 7500. I've downloaded and ran GLSetup and I get this error: "GLSetup does not contain OpenGL drivers for your display device." What I don't understand is that at GLSetup's website there is a press release about how the Radeon 8500's and 7500's have OpenGL support and whatnot. Why is it not working then? I have downloaded the latest drivers from www.ati.com. (http://www.ati.com.) Anyone else have a Radeon that can help me?

JW
01-04-2002, 11:23 AM
i have a RADEON 7200, and less than an hour ago i got direct3d and OpenGL up and running, what i did was go to my control panel and add/remove programs, you'll see it say ATI DISPLAY DRIVER and click on it and than remove it, than run glsetup to get the newest/best driver installed, BUT FIRST right when you have to restart after u uninstall the driver u have now, when windows comes back on DISABLE your anti-virus, and than run GlSetup, when it has asked you destination to put it in, put it in your windows/sysytem folder and than install it, it'll say at the end that working OpenGL drivers are on your computer, than when it restarts back, right click on desktop, click properties, than click settings, and than advanced and see if u see opengl there, if u dont, check your hardward accelator and move it to FULL, which fixed my problem moving it to FULL, and than restart and IT SHOULD WORK...

GinnaiDoma
01-04-2002, 11:38 AM
Thanx, I'll try that and let u know how it goes.

GinnaiDoma
01-04-2002, 12:00 PM
GLSetup still says It does not contain OpenGL drivers for my display device. Now I'm getting even more pissed because at ATI's site, the most recent driver I downloaded says specifically that it has Direct X 8 and OpenGL support.

JW
01-04-2002, 12:53 PM
Than I would advise you to download the driver and put in the place of glsetup, which it says glsetup is for 95/98 users, so i would do that, and do what i had told u, and see how it goes

GinnaiDoma
01-04-2002, 12:58 PM
Which driver do you mean to put in the place of?

JW
01-04-2002, 02:32 PM
download the driver from www.ati.com (http://www.ati.com) and use that driver

GinnaiDoma
01-05-2002, 07:02 AM
I have still got no OpenGL. I downloaded the drivers from ati.com and it still aint working. Anyone else have any ideas?

01-12-2002, 07:21 PM
I'm having the EXACT same problems. I've been working on this for a few days now and I haven't come up with a solve. I'll post it on here if I come up with on!

01-15-2002, 10:53 AM
i also have a radeon7500 and here is what i know : it works fine with OpenGL under Win2000pro, but owners of this card must make the difference between the cards "built by ATI" and the ones "powered by ATI". In the last case, the chip (GPU) is ATI but the drivers you must install are not the ones for ATI Built cards, but the ones who are in the "partner program" area (if i remember well); in my case, the drivers coming with my card where working fine but the card was appearing as "RV200" ; then after trying to install ATI drivers for "built by ATI" cards, i discovered that my card wasn't built by them ; so i installed the drivers for "partners products" and now, everything is OK, the card appears as "Radeon7500" and i no longer have any problem of any kind...
Hope this helps

JW
01-17-2002, 03:27 PM
put your hardware acceleration to full or else your computer will NOT even have a clue that OpenGL even exists, let alone how to work it