PDA

View Full Version : NVidia Detonator 23.11 Drivers on XP



dslater
12-18-2001, 03:12 PM
I Installed the new Detonator 23.11 drivers under Windows XP Professional. I havd a GeForce2 MX/MX 400 video card on a Dell Dimensio 8100 with a P4 1.7 GHz, 256 MB Ram & 40 GB HD. After installing the new drivers, I found that many OpenGl programs were Blue Screening me with the error that the driver had gone into an infinite loop in nv4_disp.dll. Most of the crashes happened in modules loaded by the Nvidia Effects browser ( I think these are actually Direct X programs. ) Also, I have a copy of the gears demo that I modified to use the GLUT full screen apis - this also crashed. Another problem I noticed was that for OpenGl Programs that didn't crash, if I resized the window to be larger than about 1280x1024 ( I'm running at 1600x1200x32 ), then the things slowed down to the point of being unusable ( framerate < 1 per second ). I finally uninstalled version 23.11, and re-installed version 21.83 of the detonator drivers. (Note: version 21.83 is Microsoft certified.) Has anyone else had the same problems? I am trying to figure out if this is just a bad driver version, or if I have some bad registry entries.

Another thing, even with version 23.11, I have a sample app that uses the vertex shaders which still blue screens. Do vertex shader programs execute at ring 0 and therefore bypass the normal protection that user applications have?

hocapoca
12-18-2001, 08:27 PM
I have the same exact problem.
I have a gefroce 2 GTS card
It all starts after i intall the newest driver.
it just showed a blue screen when i play 3d games.. However still havne't figure out a way to fix this...

dslater
12-19-2001, 06:02 AM
Thanks hocapoca,
I suspect that this problem is just due to a bad driver release, although I find it very strange that NVidia would release drivers with such bad bugs in them. I rolled back to version 21.83 and all seems fine. ( Version 21.83 is still on the NVidia site under driver archives)


Originally posted by hocapoca:
I have the same exact problem.
I have a gefroce 2 GTS card
It all starts after i intall the newest driver.
it just showed a blue screen when i play 3d games.. However still havne't figure out a way to fix this...

hocapoca
12-19-2001, 09:37 PM
yes. i just realize such a bad driver can cause all kind problem especially with blue screen. i even excahgne my video card ..
but now i follow your advise and use the older driver. it works perfect now. thank you very much