PDA

View Full Version : OpenGL and Baldur's Gate II



Nychold
11-22-2001, 12:51 PM
Baldur's Gate II is the only (I repeat the -ONLY- game) that will not work in 3D mode. I'm sure I have the latest drivers for my Stealth III S540 (not Xtreme) card, and for Windows 9X. Thankfully, do to my rather limited programming knowledge, I know that the problem lies in the back page flipping. OpenGL and DirectX (or whatever it's using at that point) aren't communicating well, and not flipping the back buffers correctly, so I get this weird, almost inexplicable flashing all over my screen. Basically, every where my mouse has been on the screen flashes in groups of three (triple back buffer).

HELP!!!! =)

11-22-2001, 04:10 PM
Do you have the latest patch for the game?

Lance
02-21-2004, 03:56 AM
I have the last patch for the game, and Direct X 9.0 running at Windows 98 4.0.1998.

Yeah, BG2, even with TOB expansion added, always seems to have problems working in 3D mode. I am currently using a GeForce2Mx with its latest drivers and the frames per second are completely ridicule.

Please, ŋis there a solution for Baldurīs Gate-TOB 3D acceleration, or iīm forced to play 2D as always? Itīs so frustrating....

02-21-2004, 04:04 AM
Originally posted by Lance:
I have the last patch for the game, and Direct X 9.0 running at Windows 98 4.0.1998.

Yeah, BG2, even with TOB expansion added, always seems to have problems working in 3D mode. I am currently using a GeForce2Mx with its latest drivers and the frames per second are completely ridicule.

Please, ŋis there a solution for Baldurīs Gate-TOB 3D acceleration, or iīm forced to play 2D as always? Itīs so frustrating....

Well, you are using a old video card. What is your screen resolution set to and what FPS are you getting in 3D? Are you using hardware 3D or software 3D?

According to the techincal FAQ, the BG readme.txt file has more information:
http://www.interplay.com/bgate2/technicalfaq.html

Lance
02-21-2004, 12:48 PM
640x480....and of course, 3D hardware acceleration, with ALL diplay card options running only in maximun performance chosen option.
My graphic card might be old, but the game is even more, and therefore i donīt figure that it could be an issue, since i have also used in the past a more powerful tool and the results were the same.

This annoying thing i have played and suffering every time when i was within any area of this game, i reallly canīt understandad it at all. I repeat, ŋglsetup wouldnīt help me in any way?

I suposse not if it is only an automatic proccedure for download the latest driver for my GeForce..but iīm desesperate at this point.

By the way, BG2 frames go up when i was using direct x 8.0, but i canīt play other games properly with that thing, so i havenīt got any more ideas to deal with.

Sorry for my poor english, iīm an spanish folk

Lance
02-21-2004, 01:16 PM
Yeah, i have reading the .txt files a lot of times...but i havenīt got any kind of improvement using that setting advices. In fact, the game runs almost perfectly at 2D mode with software rendering, but that makes spells effects at least 75% percent less atractive.

Anyway, is there not an opengl.org claimed word that the software render is always much slower, than the opengl 3D device controller taking care of the same function?

02-21-2004, 01:45 PM
Originally posted by Lance:

My graphic card might be old, but the game is even more, and therefore i donīt figure that it could be an issue, since i have also used in the past a more powerful tool and the results were the same.

Actually that card came out in the summer of 2000.

BG2:TOB came out in the summer of 2001, about a full year later.

And you never said what kind of FPS you're getting.

I'm afraid with such an old card and such an old game, there's not much anyone can do to help you.