PDA

View Full Version : openGL, NVIDIA GeForce FX 5700 LE, DooM3



TruEviL
12-09-2004, 04:42 AM
Hi,
Whenever I start DooM3 it crashes saying this concerning openGL :
3198 MHz Intel CPU with MMX & SSE & SSE2 & SSE3 & HTT
512 MB System Memory
256 MB Video Memory
Winsock Initialized
Hostname: master
IP: 10.0.0.140
doom using MMX & SSE & SSE2 & SSE3 for SIMD processing
enabled Flush-To-Zero mode
enabled Denormals-Are-Zero mode
------ Initializing File System ------
Current search path:
C:\Giochi\Doom 3/base
C:\Giochi\Doom 3\base\zpak001.pk4 (70 files)
C:\Giochi\Doom 3\base\pak005.pk4 (145 files)
C:\Giochi\Doom 3\base\pak004.pk4 (5137 files)
C:\Giochi\Doom 3\base\pak003.pk4 (4676 files)
C:\Giochi\Doom 3\base\pak002.pk4 (6120 files)
C:\Giochi\Doom 3\base\pak001.pk4 (8972 files)
C:\Giochi\Doom 3\base\pak000.pk4 (2698 files)
C:\Giochi\Doom 3\base\game00.pk4 (2 files)
game DLL: 0x0 in pak: 0x0
file system initialized.
--------------------------------------
----- Initializing Decls -----
------------------------------
------- Initializing renderSystem --------
using ARB renderSystem
renderSystem initialized.
--------------------------------------
4966 strings read from strings/english.lang
Couldn't open journal files
execing editor.cfg
execing default.cfg
couldn't exec DoomConfig.cfg
couldn't exec autoexec.cfg
4966 strings read from strings/english.lang
----- Initializing Sound System ------
sound system initialized.
--------------------------------------
----- R_InitOpenGL -----
Initializing OpenGL subsystem
...registered window class
...registered fake window class
...initializing QGL
...calling LoadLibrary( 'opengl32' ): succeeded
...calling CDS: ok
...created window @ 0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...attempting to use stereo
...PIXELFORMAT 10 selected
...creating GL context: succeeded
...making context current: succeeded

------- Input Initialization -------
Initializing DirectInput...
mouse: DirectInput initialized.
keyboard: DirectInput initialized.
------------------------------------
sound: STEREO
...using GL_ARB_multitexture
...using GL_ARB_texture_env_combine
...using GL_ARB_texture_cube_map
...using GL_ARB_texture_env_dot3
...using GL_ARB_texture_env_add
X..GL_ARB_texture_non_power_of_two not found
...using GL_ARB_texture_compression
...using GL_EXT_texture_filter_anisotropic
maxTextureAnisotropy: 8.000000
...using GL_1.4_texture_lod_bias
...using GL_EXT_shared_texture_palette
...using GL_EXT_texture3D
...using GL_EXT_stencil_wrap
...using GL_NV_register_combiners
...using GL_EXT_stencil_two_side
X..GL_ATI_fragment_shader not found
...using GL_ARB_vertex_buffer_object
...using GL_ARB_vertex_program
...using GL_ARB_fragment_program
...using EXT_depth_bounds_test
---------- R_NV20_Init ----------
--------------------------------------------
----- R200_Init -----
Not available.
---------- R_ARB2_Init ----------
Available.
Cg not available.
--------------------------------------------
---------- R_Exp_Init ----------
PARAM bloom0 = { 0.199501 };
PARAM bloom1 = { 0.176059 };
PARAM bloom2 = { 0.121004 };
PARAM bloom3 = { 0.064769 };
PARAM bloom4 = { 0.027000 };
PARAM bloom5 = { 0.008765 };
PARAM bloom6 = { 0.002216 };
PARAM bloom7 = { 0.000436 };
Available.
--------------------------------------------
----- R_ReloadARBPrograms -----
glprogs/test.vfp
glprogs/test.vfp
glprogs/interaction.vfp
glprogs/interaction.vfp
glprogs/bumpyEnvironment.vfp
glprogs/bumpyEnvironment.vfp
glprogs/ambientLight.vfp
glprogs/ambientLight.vfp
glprogs/shadow.vp
glprogs/R200_interaction.vp
glprogs/nv20_bumpAndLight.vp
glprogs/nv20_diffuseColor.vp
glprogs/nv20_specularColor.vp
glprogs/nv20_diffuseAndSpecularColor.vp
glprogs/environment.vfp
glprogs/environment.vfp
-------------------------------
using ARB_vertex_buffer_object memory
using ARB2 renderSystem
found DLL in pak file: C:\Giochi\Doom 3\base\game00.pk4/gamex86.dll
copy gamex86.dll to C:\Giochi\Doom 3\base\gamex86.dll
********************
ERROR: wrong game DLL API version
********************
Error during initialization
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...resetting display
...shutting down QGL
...unloading OpenGL DLL

What can I do at this point ?
Is there a place where I can download these damn files I need or something ? Please I need your help!

ZbuffeR
12-09-2004, 05:37 AM
Not related at all to OpenGL.

That may help (for win98) :
http://www.abxzone.com/forums/archive/index.php/t-83382.html

But it looks you did not buy the game...

TruEviL
12-09-2004, 06:33 AM
No in fact I didn't buy it, but I think this is not the proper problem... I have windows XP, anyone has encountered the same bugs as I have ?

ZbuffeR
12-09-2004, 08:46 AM
1) it has nothing to do, i repeat NOTHING to do with OpenGL
2) you did not buy the game

What are you doing on this forum ??? Go find more suitable ones !