PDA

View Full Version : A must know for windows 2003 I found the cure



Timmay
07-02-2003, 01:29 PM
I found this online help and it got my opengl working with windows 2003. and it opened the nvidia graphics options in display properties, so I could turn vertical sync and antialiasing off and I could get into my games. Then in counterstrike I did my fps_max 101 command and boom, 100 frames per second. Just hope this helps some of you out. full document found http://www.neowin.net/reviews/win2003_wks/Windows%20Server%202003%20as%20a%20Workstation%20G uide.doc it is how to make a windows 2003 server into a workstation. Now here is the opengl info.

By default Windows Server 2003 is hardware acceleration disabled for graphics cards, meaning only 2D and limited 3D capability is there. We can enable all this painlessly and without much effort. You will still be required to install 3D enabled drivers (like ATi Catalyst or nVIDIA Detonator drivers) for Windows 2000/XP. These can be installed on Windows Server 2003 but only after hardware acceleration is enabled will they work (and display the 3D related tabs in display properties) .

In this image you can see the default setting for the hardware acceleration, to change it to this follow these steps:

Right Click on desktop > Select "Properties" > Select "Settings" tab > Click "Advanced" > Select "Troubleshoot" tab and move the Hardware Acceleration slider all the way to "Full" > Click OK > OK

Thatís not all, DirectX (8.1) DirectDraw, Direct3D and AGP Texture Acceleration is also disabled by default on Windows Server 2003. (pic) to enable:

Click Start > Run > Type dxdiag & enter > Select Display tab > Click Enable on all Acceleration options > Click Exit

The result is Hardware Acceleration and DirectX enabled for Windows Server 2003. as you can see in the above pic I still have the default Microsoft drivers installed for my GeForce 4 Ti4400, so unless you had been previously prompted to reboot now is a good time to install those Detonator drivers (version of your choice) for Windows 2000/XP. If you use another type of card your 3D enabled drivers can be installed now. (Please remember that the latest Detonator drivers require DirectX 9)

07-02-2003, 02:05 PM
Interesting. I can't imagine anyone wanting to game on Windows Server 2003.

May I ask... is this a stand-alone computer you have it on or is this really your server? If it is your server, how many computers do you have on the network?

Timmay
07-02-2003, 02:50 PM
No itís a stand alone system. It is just something to test out new game servers that I run. And I like to make sure the new mods work well and will not mess up my main servers in my colo. http://www.opengl.org/discussion_boards/ubb/smile.gif

07-08-2003, 09:43 AM
Heh, I use Windows 2003 Server on my Dell Laptop. "Why?", you ask? Because it's a heck of a lot faster than Windows XP http://www.opengl.org/discussion_boards/ubb/smile.gif

07-08-2003, 10:29 AM
yep windows 2003 is sooooooo much faster! a bit tricky tpo setup but worth the effort, even after you've got it running really fast you can tweak it to run much faster.... lol!!

07-08-2003, 01:52 PM
Hmm, well I tried that whole thing but OpenGL still doesn't work for me. I installed the new detonator drivers from eVGA's site, and there's no difference. When trying to play Half Life with OpenGL it says that my card doesn't support that OpenGL mode. I downloaded a demo from developers.nvidia.com or whatever, and I got the error:

Necessary extensions are not supported: GL_ARB_multitexture GL_NV_texture_shader

No. of texture units = 0
../../../Common/media/textures/images/nvlogo_flip.ppm - w: 512 h: 512 ncomps: 3

I've had Half Life working before on this machine when I had XP, so I'm leaning more towards that it's a problem with Windows, I just don't know how to fix it.

08-03-2003, 11:14 AM
Timmay you are awesome. thanks for finding that and posting it. I am hosting a Quake 3 server at a local Lan party of 200 people and the admin wanted all servers on Win2k3. (Don't ask why) Anyway, I couldn't get Quake to load until I found your post and enabled the acceleration.

Thank You soooo Much !!!!

Timmay
08-03-2003, 12:33 PM
Hey no prob, glad to help, that was pissing me off so much so I figured I post it and help everyone else out. BTW you may want to chack out www.codenewbie.com (http://www.codenewbie.com) for any other kind of help too. a good forum for codeing but much more too.

yomama
08-04-2003, 09:05 AM
I posted this on another opengl area but I thought I would pass this info on this one too. OpenGL 1.4 does not work with XP (or does not work period). I hve XP and I had the latest drivers (which 1.4 was installed too). I decided to install earlier version with version 1.3 because all my games worked on it before. Viola. MOHAA and Alice works beautifully. So copy this link to install NVIDIA drivers from the archives. Choose the one that mentions Open GL version 1.3(1?) and it should fix a lot of the problems. http://www.nvidia.com/object/winxp-2k_archive.html
Hope this helps?

08-11-2003, 01:39 AM
which link has the opengl 1.3 ?

mattman
08-18-2003, 05:05 PM
I love Windows Server 2003! I'm starting a "Windows Server 2003 Gaming Club." I have never had a version of windows be so stable and so fast. Let me know if any of you are intrested.

08-20-2003, 09:31 AM
win2003 is a looot faster than pervious versions and i ran 3dmark with a similar config on my radeon 9700 and got a 1000 points more with the same drivers even.

Timmay
08-20-2003, 11:17 AM
Originally posted by mattman:
I love Windows Server 2003! I'm starting a "Windows Server 2003 Gaming Club." I have never had a version of windows be so stable and so fast. Let me know if any of you are intrested.

O would help you out, but I run linux game servers, check out the servers and my site www.HalfLife-Mods.com (http://www.HalfLife-Mods.com)

jokerx225
08-26-2003, 08:06 PM
i cannot play with battlefield 1942 on windows 2003 server why is that? i got alot of games working except that one . i have a radeon 9000pro 128mb and everytime i click the icon and it loads it comes up with the blue screen saying dumping personal memory PLS HELP!

Timmay
08-26-2003, 08:12 PM
try to reinstall the game. sounds like your getting a BSOD from it.

jokerx225
08-26-2003, 08:48 PM
sry about that its really dumping phisical memory and i did install it alot of times and it does the same with max payne to!

jokerx225
08-27-2003, 09:34 AM
this is thew error i get at the blue screen for battlefield and some other games 0x0000008e (0xc0000005, 0x82001e22, 0xba3748b8, 0x00000000)

Timmay
08-27-2003, 09:59 AM
have you tried to reinatsll the video card drivers?

jokerx225
08-27-2003, 10:27 AM
yes many times and it still is giving me problems and i also tryed re-installing directx 9 and then re-installed the drivers and it is still giving me problems

Timmay
08-27-2003, 10:32 AM
try windows updates, see and game updates. last hope format c:

jokerx225
09-10-2003, 05:44 AM
hey i havent got battlefield1942 to work and "EA" support is helping me with it and i had the same problem with Command and Conquer:GENERALS /. but im having another problem now with Midnight club 2 it loads into the menu fine and when it loads up i get a black screen but i can hear the motor when i press the arrow keys

10-14-2003, 04:40 PM
Originally posted by jdgordon:
which link has the opengl 1.3 ?

I reverted back to version 43.45 of the Nvidia detonators and my games worked

10-20-2003, 06:48 PM
Wow i havnt tried it yet but this looks like it will work, but just a note before im trying this so for my sound doesnt work and cant mess with video options when right clicking so i hope this will fix it thx for the info!

12-07-2003, 04:49 AM
Thanks for posting this info Timmay http://www.opengl.org/discussion_boards/ubb/smile.gif Was exactly what I was looking for http://www.opengl.org/discussion_boards/ubb/biggrin.gif Wonder why they disabled it in the first place???

Klaus

Timmay
12-07-2003, 07:14 AM
Hey no prob. They do that because it is server only OS and you really dont need opengl on a server.

12-10-2003, 10:35 AM
I had windows 2003 server installed on my laptop, but took it off because it didn't let me use my 3d graphics accelerator. (9600 mobility radeon)

Does anyone know if this will work with the custom drivers provided by the laptop manufacturers? If anyone has got it to work, let me know, cuz I REALLY don't want to take off XP and put on server 2003 only to have to put XP back on.

Thanks

01-08-2004, 07:48 AM
Thanx a million mate, I have had a nightmare trying to open games until I read your post. You are a life saver.



Originally posted by Timmay:
I found this online help and it got my opengl working with windows 2003. and it opened the nvidia graphics options in display properties, so I could turn vertical sync and antialiasing off and I could get into my games. Then in counterstrike I did my fps_max 101 command and boom, 100 frames per second. Just hope this helps some of you out. full document found http://www.neowin.net/reviews/win2003_wk...ion%20Guide.doc (http://www.neowin.net/reviews/win2003_wks/Windows%20Server%202003%20as%20a%20Workstation%20G uide.doc) it is how to make a windows 2003 server into a workstation. Now here is the opengl info.

By default Windows Server 2003 is hardware acceleration disabled for graphics cards, meaning only 2D and limited 3D capability is there. We can enable all this painlessly and without much effort. You will still be required to install 3D enabled drivers (like ATi Catalyst or nVIDIA Detonator drivers) for Windows 2000/XP. These can be installed on Windows Server 2003 but only after hardware acceleration is enabled will they work (and display the 3D related tabs in display properties) .

In this image you can see the default setting for the hardware acceleration, to change it to this follow these steps:

Right Click on desktop > Select "Properties" > Select "Settings" tab > Click "Advanced" > Select "Troubleshoot" tab and move the Hardware Acceleration slider all the way to "Full" > Click OK > OK

Thatís not all, DirectX (8.1) DirectDraw, Direct3D and AGP Texture Acceleration is also disabled by default on Windows Server 2003. (pic) to enable:

Click Start > Run > Type dxdiag & enter > Select Display tab > Click Enable on all Acceleration options > Click Exit

The result is Hardware Acceleration and DirectX enabled for Windows Server 2003. as you can see in the above pic I still have the default Microsoft drivers installed for my GeForce 4 Ti4400, so unless you had been previously prompted to reboot now is a good time to install those Detonator drivers (version of your choice) for Windows 2000/XP. If you use another type of card your 3D enabled drivers can be installed now. (Please remember that the latest Detonator drivers require DirectX 9)

Timmay
01-08-2004, 09:14 AM
Hey no problem, glad I could help out everyone here.

01-27-2004, 02:37 PM
Thanx a whole heap... my windows 2003 installation works perfect. And im using the latest detonator drivers (53.03)

02-01-2004, 11:46 PM
I have this same problem, BUT with a complication.

when i try to go to display properties settings/ advanced the 'advanced' option is grayed out.

how do i get past this