PDA

View Full Version : Win2k + GF4 = Fickle OpenGL



DarthGreg
02-08-2003, 12:55 PM
"The selected OpenGL mode is not supported by your video card"

Pertinent specs:

Hardware:
Asus A7V333 Mainboard - 4.42 4in1's.
Leadtek Winfast A250 TD MyVIVO GeForce 4 Ti4400 - 41.09 NVIDIA reference drivers.

Software:
Windows 2000 Professional - Service Pack 3.
DirectX 8.1.
Half-Life - 1.1.1.0..
Quake 3 - 1.32.
Unreal 2 - release.
Quake - using FuhQuake-GL 0.26.

I am what you would call a career TFC player, TFC being Team Fortress Classic which is a Half-Life modification. The problem is this: half the time I try to launch the game I get the error message, "The selected OpenGL mode is not supported by your video card." Similarly, I have problems launching my fuhquake-gl client. Unreal 2 and Quake 3, both using OpenGL, launch correctly every time.

This problem is recent, it began after transporting my PC via car from school to home about a month ago. At first, whenever I would play a 3D game (any of the listed above) I would get rhythmic pauses, varying in frequency and length, but effectively destroying any kind of playability I once had. After searching everywhere for a solution to this problem I broke down and installed a fresh copy of Win2k Pro on an extra, recently formatted, hard drive.

This eliminated the immediate problem, but once I had setup all my devices and reinstalled my games, I had a new problem: my framerate would randomly cut in half. Also, sometimes I would get the problem I am posting for now, but not quite as frequently. Installing the 4.42 4in1's eliminated most of the framerate halving, and disabling Anistropic Filtering on my card eliminated the remainder.

In the course of trying to fix this problem I have tried several versions of detonators, both 3 and 4. I cleaned my HDD and the registry of all NVIDIA files before installing new drivers. I have edited my drvmap.txt file (tells HL what OpenGL modes you have available) in the gldrv\ subdirectory of the Half-Life root directory to...

Default Default
gldrv/3dfxgl.dll 3Dfx Mini Driver
gldrv/opengl32.dll gldrv/opengl32.dll
gldrv/nvoglnt.dll gldrv/nvoglnt.dll
c:/winnt/system32/opengl32.dll system32/opengl32.dll
c:/winnt/system32/nvoglnt.dll system32/nvoglnt.dll
gldrv\opengl32.dll gldrv\opengl32.dll
gldrv\nvoglnt.dll gldrv\nvoglnt.dll
c:\winnt\system32\opengl32.dll system32\opengl32.dll
c:\winnt\system32\nvoglnt.dll system32\nvoglnt.dll
opengl32.dll opengl32.dll
nvoglnt.dll nvoglnt.dll

... where the first argument is the extension path, and the second is a label. All paths are relative to the HL root directory. The files are all correctly placed. All of these give the same "The selected OpenGL mode is not supported by your video card."

Could it be a hardware problem?

[Edit] I just tried using my brother's GF3 on the same system, and didn't have any problems launching OpenGL, but had some interesting Vsync/FSAA-related perforamance drops.

[This message has been edited by DarthGreg (edited 02-08-2003).]

02-09-2003, 01:59 PM
Man, I get the same message with my Geforce 4 mx440 ever since I upgraded to windows XP. http://www.opengl.org/discussion_boards/ubb/frown.gif

the_klint
02-10-2003, 01:41 AM
I solved my problem (could not play Half life or any other modes of the game in another way than "Sofware-mod" !! so i had no opengl nor direct3d)
my drivers are all up to date (leadtek gforce4 mx440 running on wind2k) i downloaded this file :
nVidia Refresh Rate Fix MKII for Detonator 40.41
(nividia's script modified by a programmer)
at this addresse : http://www.voodoofiles.com/7780
(it helps reshresh rates for geforces cards under windows 2000 and XP)
now half life runs smooth and fine
Features of this file
- Solves 60 Hz bug for DirectDraw, Direct3D and OpenGL
- Lets you specify refresh rates from 60 up to 240.
- Compatible to Detonator 40.41
- Also works with older Detonators, since 28.32

Description
If you have a nVidia graphics card, you'll probably know about the very common bug, that occurs together with the nVidia Detonator drivers under Windows NT/2000/XP: Normally, you can't get a higher refresh rate than 60 Hz in the OpenGL/Direct3D modes, which makes you very blind after a while of gaming. ;-) I programmed this tool, to fix this bug, since I could not find an existing tool for this on the internet, which is compatible with the new official Detonator v28.32 drivers. There already were some tools around that supported the older Detonator versions.


it didn't work for every one (on this forum)i don't know why but ! but the fact is i din't have opengl before hand and after installing this file i could play games with opengl no problem so maybe this can help u
i hope so

02-13-2003, 01:54 AM
There is no openGL suppport under windows XP ... (thanks microsoft ...)

02-14-2003, 10:05 PM
lol darthgreg... I also play TFC. You don't know me, but I see you all the time on servers like Phat Farm / Odin's Graveyard.

Anyway, I also have a GF4 Ti4400 but I'm on Windows XP and I have almost the exact same problem as you. About 3 or 4 months ago, I would frequently get problems with my fps dropping to about half their usual level.

This fixed itself somehow, but now, sometimes I get the "Your selected OpenGL mode is not supported by your video card." The only thing I can do about this is to either to try again in a few hours or to restart. Every time I've restarted after getting this, the problem temporarily went away.

I tried installing the file that theklint mentioned, but it doesn't fix the problem for me. I can't restart my computer right now, but the fix might work if I restart.

Well, I think that the problem is most likely the graphics card.

03-09-2003, 07:34 PM
Hey people,
i have been reading this and well i decided to ask you about a problem i had.

I hav a nvideo geforce 2mx 200, 128mb ram, 350mhz processor.

Now whenever i play Day of Defeat, it runs really slow, is there some way to speed this up or something.?

03-15-2003, 01:25 AM
i discovered this error is caused by irc for me. if irc is turned off while playing it works. this error doesn't only occur in certain games but in every application that uses the opengl mode. some ppl state their quake3 still works fine but if u look close at the graphics u see it looks somewhat different because quake automatically switches to some weird software mode. this was at the beginning now quake3 doesn't even start anymore and tells me "could not initialize opengl subsystem" in the console.
i went some deeper into the problem and saw that some but not all mirc-scripts cause this error. for example if i use the standard irc-client without any script it works fine. another thing to mention is that opengl still works fine when i am in not so many channels so maybe it has something to do with cpu-cycles already used ?

03-19-2003, 10:12 AM
I had a similar problem and I was able to solve it. Here is what worked in my case, may be it will help somebody.

I have GeForce4 Ti4200, P4 and Win2000. Suddenly all 3D accelerated apps (from Winamp plugins to Hartwood Solitire to Quake) started having small pauses every 10 seconds or so. I checked in the Task Manager and found out that services.exe was loading the CPU to 100% every 10 sec. The same might be happening in your case. Using task manager you can easily find the offending process. If it is some application, like mirc, you can just uninstall it, reconfigure, change the process priority to Low or something. In my case it was more complicated because services.exe is a system process that runs all (guess what?) services and the priority cannot be changed. I opened Control Panel/Administrative Tools/Services and started stopping services one by one. I found that DNS client was responsible. The problem was that when my Inet connection (cable) died, the DNS client would go crazy. So I was able to solve it either by temporarily disabling the cable mode (in device manager) when the connection is down, or just waiting until it works again. http://www.opengl.org/discussion_boards/ubb/smile.gif

03-24-2003, 04:56 AM
I've also had the problem with "The selected open gl mode is not supported by your video card" in HL. I'm using a GF4 Ti4200 card with AGP8x, and win XP sp1.

Like one of the above, i finally found that it was my irc script that made my PC deny me the right to play CS in OpenGL mode. This script btw, is tribe theme for ircN7.27, so now you're warned.

Anyway, thanks for the help http://www.opengl.org/discussion_boards/ubb/biggrin.gif

04-06-2003, 04:20 AM
So the answer to this problem is..?

04-07-2003, 03:08 AM
yes thank god i have found people with a similiar problem.... basically i had a wicked system set up (1900xp gf3) and cs would run fine.... however i have been getting the dreaded opengl mode is not supported.... now this only started happening when i installed nnscript on mirc. now this is a great script but its stoppin me from playin cs. if i close mirc i can play cs fine but thats pointless.

tried lots of det drivers but nothing makes a difference. i migth try setting low priority for mirc cos in task manager it is bursting a lot http://www.opengl.org/discussion_boards/ubb/smile.gif

thanks

04-07-2003, 03:29 AM
hmm i dunno but this might be a clue. i reckon x0r might be onto sommin with the cpu cycle thing cos if i look at task manager then move my mirc about, the cpu usage spikes to 80 or so. (btw i have nnscript running, before installin this good script everyting was fine). so my guess is that when i launch cs or sommin cos the desktop gets changed (liek when i come back to desktop from cs all the windows are reshaped and moved about) that there is a cpu burst in usage and that causes the opengl not to iniitialise. hmm i tried irc in low priority but no joy

04-07-2003, 03:38 AM
ahh guys with the mirc script/ opengl prob. i just fixed mine. basically i disabled my background mirc wallpaper (had a wallpaper in the channels) and then disabled nnscript lag bar. loaded cs fine and played. so i put the lag bar back on and tried, still ok. put the mirc background on, and bham it dies...

hope this helps. if u dont have nnscript or background wallpapers in mirc then all i can suggest is just use a vanilla mirc. sucks i know but its all i can think of

hth

05-05-2003, 07:27 PM
okay...like everyone else here, i cant get my freakin opengl mode to work for counter-strike. im runnin on an ATI Rage 128 GL AGP with win xp...ive tried getting updates, opengl installs off this site, but nothing seems to work. anyone got any ideas or anything that could help me with this situation?
p.s. i can run d3d but not opengl...if thats any help http://www.opengl.org/discussion_boards/ubb/confused.gif

05-10-2003, 10:13 AM
hey i get a 10 seconds lag every server plz help me i dont no wot to do lol

06-02-2003, 12:33 AM
bleh, i have the same problem, but i don t have mirc or anything else running....

Win2k PIII 1k
GF4 440mx 512 ram

06-22-2003, 01:29 PM
This is all bull****. Im tired of these big companies that we shell out our cash to telling us its "not their problem contact so and so" or whatever. BLAH!

One of the super nerds that work at these companies needs to get off their fat ass and examine the problems we are having.

Its a shame that I gave up a 3dfx Voodoo 3 2000 PCI card that was 16 megs for a nvidia geforce 64 meg agp card that doesnt even run the damn game or if it does gives me 20 fps.

This **** right here is why people pirate software. No one wants to pay for stuff they have to haggle to work.

So one of you mother****ers fix the problem.
>SLAP< in ya eye biatch!

06-23-2003, 01:24 AM
***DO NOT REPLY TO THIS EMAIL***

NVIDIA's support system is all processed online via the web.

To send e-mail to NVIDIA click on this link (http://support.nvidia.com/apps/EndUserSupport/index.asp).

Before sending e-mail, please visit these links for answers to commonly asked questions:

* Product Information (http://www.nvidia.com/view.asp?PAGE=products)
* Where to Buy (http://www.nvidia.com/content/wheretobuy/consumer.asp)
* Software Features (http://www.nvidia.com/view.asp?IO=software)
* Frequently Asked Questions (FAQ) (http://www.nvidia.com/view.asp?PAGE=support_faqs)
* Tutorials (http://www.nvidia.com/view.asp?PAGE=pg_20011106217193)
* Driver Download (http://www.nvidia.com/content/drivers/drivers.asp)
* PC or Add-In Card Manufacturers (http://www.nvidia.com/view.asp?PAGE=support)


Thank you,
NVIDIA Support Team