PDA

View Full Version : Possible fix for OGL subsystem error



Halcyon
01-08-2003, 07:35 PM
Ok, i've noticed this forum is basically made up of OpenGL subsystem problems on games like Wolf and Medal of Honor.

If you have Win ME or Win XP, i highly recomend that you try to download the latest video card drivers (especially if your card is made by Nvidia or ATI).

I'm not tell you that your video card is messed up or anything. Windows comes with OpenGL drivers that support OpenGL 1.1. The current standard is OpenGL 1.4 and OpenGL 2.0 is on its way. There are lots of extra features that were added in for OGL 1.4 that OGL 1.1 drivers don't support. When you get new video card drivers for your card, you get their OpenGL drivers too!

So all those extra features that Nvidia cards have will be suported in the OpenGL drivers they provide. Since they want to access the state of the art technology, they will have the most current version of OpenGL in their drivers.

If anyone is wondering why Windows comes with OpenGL 1.1, it is because of DirectX. After they created DirectX, they did not want to keep updating OpenGL drivers because that is their only real competition in the market (you know microsoft's tactics).

I know this has worked for a lot of people in here, so just try it out. It really can't hurt and you'll have the latest stuff (it can actually mean faster graphics!).

- Halcyon