PDA

View Full Version : Can not use OpenGL suddenly



Jackylam
08-08-2003, 08:40 AM
Hello all,
I can not use OpengGL lib suddenly, I think it is properly due to software conflict. Because I realize that when I install some new software, and the opengl fault. The message from the opengl now showing is:
GLUT: Fatal Error in (unamed): failed to create OpenGL rendering context.
Anyone knows how to solve this kind of tedious problem. The OS I used is XP professional.

08-03-2004, 04:32 AM
I got the same problem with XP Professional and OpenGL. Everything worked fine till one day when this error occurred (GLUT Fatal error in $.exe : failed to create OpenGL rendering context).

I read in another forum this post :
"I have that happen ocassionally, I think it's a problem where the rendering system has been locked up from the previous application. I think it's a bug stemming from dx9 debug stuff. It seems to just go away on it's own accord and I've never seen it with the retail version of DX9 so I don't worry about it."

And indeed, it seems to appear and go away without any reason.

manastone
09-05-2004, 09:23 PM
This is the same problem I am having now! Though for me, it won't go back to normal. Does anyone know how I can fix this?

09-19-2004, 12:47 PM
I have the same problem
The only way to run opengl I found is to run any quickly loading opengl application immediately after windows is started. Short time after windows is started but not all drivers and services are loaded (near 10-20 sec after desktop showing) I run simple opengl program. After this opengl becomes available. May be it helps you.