PDA

View Full Version : opengl based games not working on GF4



04-11-2002, 10:11 AM
Got a new g-force4 mx420, and can't run H-L, or jedi in open gl.H-L works fine in d3d,
and jedi doesn't give you the option. When i start H-L, the game will load and then my
screen splits into 2 and the game will be in the upper half and the bottom half is all
jumbled with vertical lines, the same with jedi. The only way back to normal is by
rebooting.I am not having the problem everyone else is having with "opengl subsystem can't load" I have a amd athalon 1.6, win 98, 384 megs ram. Also the instuctions for the
g-force state that direct x8.1 must be loaded to run the card , this came with the card
on a cd. i think it's the open gl cause d3d games work fine. I have all updated drivers from evida, directx 8.1, ect. i'd like to know if anyone else
is having the same prob. all suggestions will be appreciated. thanx in advance.

04-15-2002, 01:38 AM
Lo,

I am having the same problem, have GeForce4 MX 440, 64mb and have installed on Win2k. C&C Renegade and DFLand Warrior work fine. Halflife however will only work in D3D mode, not OpenGL,

If any one has any ideas please speak up !!, p.s. I have tried removing HL and reinstalling, no joy

thanks

Snaga

05-14-2002, 09:16 AM
did you have any luck resolving? I've got the same problem, win98. xp1700, mx440. only opengl apps... tried all new drivers etc... no luck



Originally posted by Termite:
Got a new g-force4 mx420, and can't run H-L, or jedi in open gl.H-L works fine in d3d,
and jedi doesn't give you the option. When i start H-L, the game will load and then my
screen splits into 2 and the game will be in the upper half and the bottom half is all
jumbled with vertical lines, the same with jedi. The only way back to normal is by
rebooting.I am not having the problem everyone else is having with "opengl subsystem can't load" I have a amd athalon 1.6, win 98, 384 megs ram. Also the instuctions for the
g-force state that direct x8.1 must be loaded to run the card , this came with the card
on a cd. i think it's the open gl cause d3d games work fine. I have all updated drivers from evida, directx 8.1, ect. i'd like to know if anyone else
is having the same prob. all suggestions will be appreciated. thanx in advance.

bradosc
05-14-2002, 10:12 PM
I recently upgraded (or so I thought) to PNY Technologies nVidia GeForce 4 MX420. I am having the same problem when I try to play Half-Life: Counter Strike. The game says,"your video card does not support Open Gl mode". It will play in Direct 3d mode, but the game doesn't play as well (choppy, blurry). This really stinks since my previous card (3dfx Voodoo3) ran the game pretty good. Hope someone can find a fix to this, or else I'm considering throwing my system out the window...frustrating!

System specs:
Gateway
Windows 98 SE
Intel Pentium III 500 Mhz
16+ GB Hard Drive
256 MB SDRAM
SoundBlaster audio
64 MB PNY Technologies nVidia Geforce4 MX 420
Cable modem (through router)

Brad.

yakuza
05-15-2002, 07:19 AM
Brad, did you uninstall your Voodoo3 driver before loading the new Geforce4? Have you installed the drivers for your new card?

Also, make sure you have DirectX8.1 loaded, I've seen issues where OpenGL wouldn't work with Nvidia drivers without DirectX8.1 being loaded. Click "Start", then "Run", then type "dxdiag" and hit enter, you should see your DirectX version there.

bradosc
05-15-2002, 12:16 PM
yakuza,

When I bought my Gateway system, it came with 3Dfx Voodoo3 video card already installed. Before I installed my GeForce4 card, I ran add/remove programs (from control panel) to remove all of my Voodoo3 crap. Then I installed the GeForce4 card, followed the on screen instructions, then updated the drivers for the card (got the updates off of the nVidia website- Detonator driver was most up-to-date driver I found- used the Win 98 version).

I thought the disc that came with the Geforce4 card would have/did (cant remember if I saw it during installation) come with DirectX8.1. I'll do what you said, and see what version I am running... I'll get back to you.
Brad.

bradosc
05-15-2002, 12:28 PM
yakuza,

Just ran your dxdiag thing. It says my system is running DirectX 8.1 (4.08.01.0881). Hope this helps! Brad.

yakuza
05-15-2002, 03:40 PM
Hmmmm... well, it really does sound like a driver issue. How about other OpenGL games/apps? Can you get any to run, or other Quake3 based games? Are you overclocking, or could heat be an issue?

You could see if PNY offers any drivers directly, and try the version they offer. It's possible (but highly unlikely) that the manufacturer has some dependencies that makes the card want their drivers.

There's a utility called "GLinfo" that detects your graphic card hardware support and other OpenGL support information, why don't you try it and see what it outputs for your card? Perhaps it's not being recognized correctly. http://www.delphi3d.net/hardware/index.php

bradosc
05-15-2002, 07:05 PM
yakuza,
I really don't play any other games beside Half-Life:CounterStrike. Scared to findout that they dont work either, and a lot of the new games coming out I know my system won't be able to handle them.

How do I find out if I'm overclocking or have heat issues? I'm not to "computer-savy" so you'll have to walk me through the steps, sorry.

I did the GLinfo thing, here are the results:
Driver version: 4.13.1.2832
Vendor: Microsoft Corporation
Renderer: GDI Generic
Open Gl version: 1.1.0

It told me a whole bunch of other stuff (under different tabs). It is too much weird titles/numbers stuff so I didnt write it down. Hopefully what I provided will be enough, if you need the other stuff I will take the time to post it. I have a feeling that my computer is running graphics through the generic "motherboard" video card that came with the computer, is there such a thing? If so, how do I fix this?

When I go to the PNY site, they send me to nVidia site for any drivers... I guess they don't have any of their own.

Thanks for taking your time with me. It must get frustrating talking to computer-illiterate people. Brad.

yakuza
05-16-2002, 07:08 AM
Originally posted by bradosc:

I did the GLinfo thing, here are the results:
Driver version: 4.13.1.2832
Vendor: Microsoft Corporation
Renderer: GDI Generic
Open Gl version: 1.1.0


See where it says "Microsoft", and "GDI Generic"? This means that your system doesn't have correct OpenGL drivers installed, so it's defaulting to Software OpenGL mode (horribly slow and little support for newer features).

Here's what I would do...
- Make sure you have the latest driver downloaded from Nvidia
- Un-install the Nvidia drivers from your "Add/Remove Programs" Control Panel.
- If you know how to use Regedit, search for all instances of "3dfx" and "Voodoo" in the registry, and delete any keys that reference those
- Restart your computer
- When it detects your Geforce4 card upon restart, hit "Cancel" so that it doesn't try to load any drivers for it.
- Install the drivers from Nvidia. You'll probably have to restart again

At this point, hopefully everything will be good. Run that GLinfo again, and it should say "Nvidia" for the Vendor, and have a version of 1.3.xxxx for the Version. If not, ... well, we'll address that problem if it happens. http://www.opengl.org/discussion_boards/ubb/smile.gif



Thanks for taking your time with me. It must get frustrating talking to computer-illiterate people. Brad.


When people can present questions in a well thought-out manner with a friendly attitude (such as yourself), it's my pleasure to help out. http://www.opengl.org/discussion_boards/ubb/smile.gif

yakuza
05-16-2002, 07:11 AM
I have a feeling that my computer is running graphics through the generic "motherboard" video card that came with the computer, is there such a thing? If so, how do I fix this?


Crap, I just saw this in your previous post. Yes, it could definitely be detecting the onboard video. Do you know how to go into the BIOS of your computer? Before windows loads, and it's doing the memory count, you should be able to hit "Del" or "F1" or something like that, and enter a Setup screen. If you can, check if you can disable onboard video through those settings.

dorbie
05-16-2002, 08:35 AM
Interesting but I'm not convinced by the theory here.

You have to consider where his monitor video coming from the system. I mean it's one thing to speculate about some mobo freeD, quite another to expect that video to come from your GeForce4.

I mean the guy must have his monitor connected to his new GF4 card so that's whats' running.

Anyway, DO install the latest nvidia drivers.

bradosc, did you install the drivers that came with the PNY on CDROM? Did you get any errors in doing so?

yakuza
05-16-2002, 09:46 AM
Regardless of where the video feed is coming from, if the system detects multiple video devices (Geforce4 in AGP slot, and onboard video) who knows what device OpenGL will default to?



You have to consider where his monitor video coming from the system. I mean it's one thing to speculate about some mobo freeD, quite another to expect that video to come from your GeForce4.

I could hook my monitor up to my toaster, doesn't mean it's going to attempt to use my toaster's video device for output. http://www.opengl.org/discussion_boards/ubb/biggrin.gif

Brad said he downloaded and installed latest Nvidia drivers, and that the PNY website directs users to the Nvidia site for drivers, so I would assume that the PNY CD contains Detonators.

I agree it's probably a driver issue, but I can't discount the possibility of onboard video conflicting with the new card.

My 2 cents.. http://www.opengl.org/discussion_boards/ubb/smile.gif

bradosc
05-16-2002, 02:18 PM
yakuza,

I tried what you said, but the results are the same: counterstrike says,"your video card does not support Open Gl mode" and the Glinfo thing is still showing the same information.

I'm starting to lose hope. Brad

yakuza
05-16-2002, 04:04 PM
Were you able to access your system BIOS and see if you could disable the onboard video? Check the Device Manager too, make sure it's only seeing the Geforce card.
Right-click "My Computer", select "Properties", then "Device Manager", the video card should be under "Display Adapters".

What's the Gateway model number of your system?

bradosc
05-16-2002, 05:41 PM
yakuza,

I made it into my system BIOS (by hitting F1 during start-up) but didn't see anything for disabling onboard video. I looked under every tab it offered me.

I then checked under Device Manager/ Display Adapters... and it showed: nVidia GeForce4 MX 420 (the right one, and it was the only one showing).

My Gateway model is: Gateway Performance 500.

Again, thanks for your helpfulness. Hopefully we can figure this out (or you can lol). Brad.

yakuza
05-17-2002, 07:03 AM
Well, I'm afraid I'm about fresh out of ideas. Do you still have the manual for the computer? Look around for a jumper to disable the onboard video, it would be on the motherboard somewhere if it exists.

Other than that, my next step would be to format the drive and reload Windows. Unfortunately, if you're not experienced with that, I wouldn't recommend you do it by yourself.

Sorry Brad, wish I had a miracle answer for you, good luck.