PDA

View Full Version : and another opengl question



MATvm
02-10-2005, 09:38 AM
sorry to bother u guys again with this problem, but here goes nothing;

I have a P4 WIN XP Pro 2.66Ghz, ATI RADEON 128 MB, 512 DDR RAM, ...
so here's my problem;

I recently formatted my PC but when i try to play Call of Duty, i get the error message:

COD 1.0 build win-x86 Oct 5 2003
----- FS_Startup -----
Current language: english
Current search path:
C:\MAT\Game\CALLOF~1\main\pakb.pk3 (60 files)
C:\MAT\Game\CALLOF~1\main\paka.pk3 (41 files)
C:\MAT\Game\CALLOF~1\main\pak9.pk3 (149 files)
C:\MAT\Game\CALLOF~1\main\pak8.pk3 (235 files)
C:\MAT\Game\CALLOF~1\main\pak6.pk3 (3 files)
C:\MAT\Game\CALLOF~1\main\pak5.pk3 (4858 files)
C:\MAT\Game\CALLOF~1\main\pak4.pk3 (1668 files)
C:\MAT\Game\CALLOF~1\main\pak3.pk3 (1992 files)
C:\MAT\Game\CALLOF~1\main\pak2.pk3 (694 files)
C:\MAT\Game\CALLOF~1\main\pak1.pk3 (2642 files)
C:\MAT\Game\CALLOF~1\main\pak0.pk3 (12828 files)
C:\MAT\Game\CALLOF~1/main
C:\MAT\Game\CALLOF~1\main\localized_english_pak5.p k3 (46 files)
localized assets pak file for english
C:\MAT\Game\CALLOF~1\main\localized_english_pak3.p k3 (7 files)
localized assets pak file for english
C:\MAT\Game\CALLOF~1\main\localized_english_pak2.p k3 (9 files)
localized assets pak file for english
C:\MAT\Game\CALLOF~1\main\localized_english_pak1.p k3 (3736 files)
localized assets pak file for english
C:\MAT\Game\CALLOF~1\main\localized_english_pak0.p k3 (1204 files)
localized assets pak file for english

File Handles:
----------------------
30172 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec config.cfg
couldn't exec autoexec.cfg
========= autoconfigure
configure.csv: using configuration 2000 cpu MHz 512 sys MB 128 vid MB
execing configure.cfg
fs_basepath is write protected.
fs_homepath is write protected.
Hunk_Clear: reset the hunk ok
...detecting CPU, found Intel Pentium III
Measured CPU speed is 2.59 GHz
System memory is 511 MB (capped at 1 GB)
Video card memory is 128 MB
Streaming SIMD Extensions (SSE) supported

----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\system32\opengl32.dll' ): succeeded
...setting mode 6: 1024 768 FS
...using colorbits of 32
...calling CDS: ok
...registered window class
...created window@0,0 (1024x768)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 32, 24, 8 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 32, 24, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (6)
...shutting down QGL
...unloading OpenGL DLL
Forcing 800x600 resolution to allow OpenGL to run in fullscreen
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\system32\opengl32.dll' ): succeeded
...setting mode 4: 800 600 FS
...using colorbits of 32
...calling CDS: ok
...created window@0,0 (800x600)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 32, 24, 8 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 32, 24, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (4)
...shutting down QGL
...unloading OpenGL DLL
Forcing 640x480 resolution to allow OpenGL to run in fullscreen
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\system32\opengl32.dll' ): succeeded
...setting mode 3: 640 480 FS
...using colorbits of 32
...calling CDS: ok
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 32, 24, 8 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 32, 24, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...shutting down QGL
...unloading OpenGL DLL
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
Hunk_Clear: reset the hunk ok
Could not load OpenGL. Make sure that you have the latest drivers for your video card from the manufacturer's web site.

*Note that i was able to play all kinds of games (cod, bf 1942,... before my format) (weird thing is i can play bf 1942 but not cod :S )*

so i updated drivers from ATI site and so on, still same problem...

I end up here and check some topics so i tried also the check with the GLinfo program and it says;

GLinfo report

Driver info
Driver version Unknown
Vendor Microsoft Corporation
Renderer GDI Generic
OpenGL version 1.1.0

Extension lists
Extensions GL_EXT_bgra
GL_EXT_paletted_texture
GL_WIN_swap_hint
WGL extensions

Implementation specifics
Various limitations Max. texture size 1024 x 1024
Max. number of light sources 8
Max. number of clipping planes 6
Max. pixel map table size 65536
Max. display list nesting level 64
Max. evaluator order 30
Point size range 0,500 to 10,000
Point size granularity 0,125
Line width range 0,500 to 10,000
Line width granularity 0,125

Maximum stack depths Modelview matrix stack 32
Projection matrix stack 10
Texture matrix stack 10
Name stack 128
Attribute stack 16

Framebuffer properties Sub-pixel precision bits 3
Max. viewport size 16384 x 16384
Number of auxiliary buffers 0


so i know there's something wrong because it says microsoft with drivers....

But now i don't know what to do any more.

Could you help me out

thx

ZbuffeR
02-10-2005, 03:01 PM
Really sure you installed correctly a recent ATI Catalyst video driver ? It does't seems so.

MATvm
02-11-2005, 07:16 AM
thx for quick response.

Problem solved now, had to reinstall drivers but problem was in my regedit (couldn't remove a key)

Thx