PDA

View Full Version : AGH! More GL problems



01-03-2003, 08:55 PM
I actually solved the subsystem problem buuuuut.... the intros don't work, the mouse is out of control, and when i try to play it gives this message!
--- Common Initialization ---
Medal of Honor Allied Assault 1.00 win-x86 Dec 6 2001
----- FS_Startup -----
Current search path:
C:\PROGRA~1\EAGAME~1\MOHAA\main\Pak5.pk3 (259 files)
C:\PROGRA~1\EAGAME~1\MOHAA\main\Pak4.pk3 (593 files)
C:\PROGRA~1\EAGAME~1\MOHAA\main\Pak3.pk3 (669 files)
C:\PROGRA~1\EAGAME~1\MOHAA\main\Pak2.pk3 (4722 files)
C:\PROGRA~1\EAGAME~1\MOHAA\main\Pak1.pk3 (772 files)
C:\PROGRA~1\EAGAME~1\MOHAA\main\Pak0.pk3 (11175 files)
C:\PROGRA~1\EAGAME~1\MOHAA/main

----------------------
18190 files in pk3 files
execing default.cfg
execing menu.cfg
execing newconfig.cfg
Config: unnamedsoldier.cfg
execing configs/unnamedsoldier.cfg
couldn't exec localized.cfg
execing autoexec.cfg
Unknown command "fov"
couldn't exec custom.cfg
...detecting CPU, found Intel Pentium III

------- Input Initialization -------
Initializing DirectInput...
Couldn't set DI coop level
Falling back to Win32 mouse support...
------- Input Initialization Complete ------- 149
You are now setup for easy mode.
----- Client Initialization -----
Called FadeSound with: 0.000000
----- Initializing Renderer ----
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\System32\opengl32.dll' ): succeeded
...setting mode 4: 800 600 FS
...using colorsbits of 16
...calling CDS: ok
...registered window class
...created window@0,0 (800x600)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...19 PFDs found
...hardware acceleration found
...PIXELFORMAT 2 selected
...creating GL context: succeeded
...making context current: succeeded
Initializing OpenGL extensions
...GL_EXT_texture_compression_s3tc not found
...GL_ARB_texture_compression not found
...GL_EXT_texture_env_add not found
...WGL_EXT_swap_control not found
...GL_ARB_multitexture not found
...GL_EXT_texture_env_combine not found
...GL_EXT_compiled_vertex_array not found
...WGL_3DFX_gamma_control not found

GL_VENDOR: SciTech Software, Inc.
GL_RENDERER: GLDirect NVIDIA GeForce2 MX/MX 400
GL_VERSION: 1.2 Mesa 3.1
GL_EXTENSIONS: GL_EXT_blend_color
GL_EXTENSIONS: GL_EXT_blend_minmax
GL_EXTENSIONS: GL_EXT_blend_logic_op
GL_EXTENSIONS: GL_EXT_blend_subtract
GL_EXTENSIONS: GL_EXT_vertex_array
GL_EXTENSIONS: GL_EXT_texture_object
GL_EXTENSIONS: GL_EXT_texture3D
GL_EXTENSIONS: GL_MESA_window_pos
GL_EXTENSIONS: GL_MESA_resize_buffers
GL_EXTENSIONS: GL_EXT_rescale_normal
GL_EXTENSIONS: GL_EXT_abgr
GL_EXTENSIONS: GL_NV_texgen_reflection
GL_EXTENSIONS: GL_EXT_paletted_texture
GL_EXTENSIONS: GL_EXT_shared_texture_palette
GL_EXTENSIONS: 3DFX_set_global_palette
GL_MAX_TEXTURE_SIZE: 1024
GL_MAX_ACTIVE_TEXTURES_ARB: 0

PIXELFORMAT: color(16-bits) Z(16-bit) stencil(0-bits)
MODE: 4, 800 x 600 fullscreen hz:60
GAMMA: hardware w/ 0 overbright bits
CPU: Intel Pentium III
rendering primitives: multiple glArrayElement
texturemode: GL_LINEAR_MIPMAP_NEAREST
picmip: 2
texture bits: 16
multitexture: disabled
compiled vertex arrays: disabled
texenv add: disabled
compressed textures: disabled
Initializing Shaders
Setting up Shaders
----- finished R_Init -----
------- profiling DrawBackground methods -------
glDrawPixels w/ BGR: 9541394 clocks
glDrawPixels w/ RGB: 9709588 clocks
glTexSubImage2D w/ BGR: 6994364 clocks
glTexSubImage2D w/ RGB: 3523832 clocks
DrawBackground: using glTexSubImage2D with RGB data
-------------------------------
------ Force Feedback Initialization -----
Loading ff...
ff: Creating feedback device:
ff: ...no ff mouse found
Failed to load ff dll
------------------------------------------
--------- Force Feedback Shutdown --------
------------------------------------------
Winsock Initialized
Opening IP socket: localhost:12203
Hostname: suetorbeck
IP: 63.215.175.40
------- Sound Initialization (full) -------
Sound opened using Direct Sound
'Miles Fast 2D Positional Audio' provider opened.
Loading global/sound0.txt
------- S_StopAllSounds (stop music) -------
------- S_StopAllSounds Complete-------
----- Sound Info -----
driver - Miles Fast 2D Positional Audio
speaker setup - 2 speakers
reverb - OFF
samplebits - 16
speed - 22050
----------------------
------- Sound Initialization Complete ------- 1377 ms
Setting up Shaders
Loading inventory...
----- Client Initialization Complete ----- 9608 ms
--- Common Initialization Complete --- 16838 ms
Working directory: C:\PROGRA~1\EAGAME~1\MOHAA
Loading Localization File global/localization.txt
------- S_StopAllSounds (stop music) -------
------- S_StopAllSounds Complete-------
trFMV: http://www.opengl.org/discussion_boards/ubb/tongue.giflay(), playing EAlogo.RoQ
------- S_StopAllSounds (stop music) -------
------- S_StopAllSounds Complete-------
trFMV: http://www.opengl.org/discussion_boards/ubb/tongue.giflay(), playing 2015intro.RoQ
------- S_StopAllSounds (stop music) -------
------- S_StopAllSounds Complete-------
trFMV: http://www.opengl.org/discussion_boards/ubb/tongue.giflay(), playing intro.RoQ
-------- CL_Vid_Restart_f --------
------- Sound Begin Registration -------
------- S_StopAllSounds (stop music) -------
------- S_StopAllSounds Complete-------
------- Sound Begin Registration Complete -------
RE_Shutdown( 1 )
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...hiding window
...destroying window
...window successfully destroyed
...resetting display
...shutting down QGL
...unloading OpenGL DLL
----- Initializing Renderer ----
----- R_Init -----
Cmd_AddCommand: r_infostaticmodels already defined
Cmd_AddCommand: r_infoworldtris already defined
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\System32\opengl32.dll' ): succeeded
...setting mode 4: 800 600 FS
...using colorsbits of 16
...calling CDS: ok
...created window@0,0 (800x600)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...19 PFDs found
...hardware acceleration found
...PIXELFORMAT 2 selected
...creating GL context: succeeded
...making context current: succeeded
Initializing OpenGL extensions
...GL_EXT_texture_compression_s3tc not found
...GL_ARB_texture_compression not found
...GL_EXT_texture_env_add not found
...WGL_EXT_swap_control not found
...GL_ARB_multitexture not found
...GL_EXT_texture_env_combine not found
...GL_EXT_compiled_vertex_array not found
...WGL_3DFX_gamma_control not found

GL_VENDOR: SciTech Software, Inc.
GL_RENDERER: GLDirect NVIDIA GeForce2 MX/MX 400
GL_VERSION: 1.2 Mesa 3.1
GL_EXTENSIONS: GL_EXT_blend_color
GL_EXTENSIONS: GL_EXT_blend_minmax
GL_EXTENSIONS: GL_EXT_blend_logic_op
GL_EXTENSIONS: GL_EXT_blend_subtract
GL_EXTENSIONS: GL_EXT_vertex_array
GL_EXTENSIONS: GL_EXT_texture_object
GL_EXTENSIONS: GL_EXT_texture3D
GL_EXTENSIONS: GL_MESA_window_pos
GL_EXTENSIONS: GL_MESA_resize_buffers
GL_EXTENSIONS: GL_EXT_rescale_normal
GL_EXTENSIONS: GL_EXT_abgr
GL_EXTENSIONS: GL_NV_texgen_reflection
GL_EXTENSIONS: GL_EXT_paletted_texture
GL_EXTENSIONS: GL_EXT_shared_texture_palette
GL_EXTENSIONS: 3DFX_set_global_palette
GL_MAX_TEXTURE_SIZE: 1024
GL_MAX_ACTIVE_TEXTURES_ARB: 0

PIXELFORMAT: color(16-bits) Z(16-bit) stencil(0-bits)
MODE: 4, 800 x 600 fullscreen hz:60
GAMMA: hardware w/ 0 overbright bits
CPU: Intel Pentium III
rendering primitives: multiple glArrayElement
texturemode: GL_LINEAR_MIPMAP_NEAREST
picmip: 2
texture bits: 16
multitexture: disabled
compiled vertex arrays: disabled
texenv add: disabled
compressed textures: disabled
Initializing Shaders
Setting up Shaders
----- finished R_Init -----
------- profiling DrawBackground methods -------
glDrawPixels w/ BGR: 6434182 clocks
glDrawPixels w/ RGB: 10872708 clocks
glTexSubImage2D w/ BGR: 3283644 clocks
glTexSubImage2D w/ RGB: 3158440 clocks
DrawBackground: using glTexSubImage2D with RGB data
-------------------------------
Setting up Shaders
----- finished CL_Vid_Restart_f ----
-------- CL_Vid_Restart_f --------
------- Sound Begin Registration -------
------- S_StopAllSounds (stop music) -------
------- S_StopAllSounds Complete-------
------- Sound Begin Registration Complete -------
RE_Shutdown( 1 )
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...hiding window
...destroying window
...window successfully destroyed
...resetting display
...shutting down QGL
...unloading OpenGL DLL
----- Initializing Renderer ----
----- R_Init -----
Cmd_AddCommand: r_infostaticmodels already defined
Cmd_AddCommand: r_infoworldtris already defined
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\System32\opengl32.dll' ): succeeded
...setting mode 4: 800 600 FS
...using colorsbits of 16
...calling CDS: ok
...created window@0,0 (800x600)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...19 PFDs found
...hardware acceleration found
...PIXELFORMAT 2 selected
...creating GL context: succeeded
...making context current: succeeded
Initializing OpenGL extensions
...GL_EXT_texture_compression_s3tc not found
...GL_ARB_texture_compression not found
...GL_EXT_texture_env_add not found
...WGL_EXT_swap_control not found
...GL_ARB_multitexture not found
...GL_EXT_texture_env_combine not found
...GL_EXT_compiled_vertex_array not found
...WGL_3DFX_gamma_control not found

GL_VENDOR: SciTech Software, Inc.
GL_RENDERER: GLDirect NVIDIA GeForce2 MX/MX 400
GL_VERSION: 1.2 Mesa 3.1
GL_EXTENSIONS: GL_EXT_blend_color
GL_EXTENSIONS: GL_EXT_blend_minmax
GL_EXTENSIONS: GL_EXT_blend_logic_op
GL_EXTENSIONS: GL_EXT_blend_subtract
GL_EXTENSIONS: GL_EXT_vertex_array
GL_EXTENSIONS: GL_EXT_texture_object
GL_EXTENSIONS: GL_EXT_texture3D
GL_EXTENSIONS: GL_MESA_window_pos
GL_EXTENSIONS: GL_MESA_resize_buffers
GL_EXTENSIONS: GL_EXT_rescale_normal
GL_EXTENSIONS: GL_EXT_abgr
GL_EXTENSIONS: GL_NV_texgen_reflection
GL_EXTENSIONS: GL_EXT_paletted_texture
GL_EXTENSIONS: GL_EXT_shared_texture_palette
GL_EXTENSIONS: 3DFX_set_global_palette
GL_MAX_TEXTURE_SIZE: 1024
GL_MAX_ACTIVE_TEXTURES_ARB: 0

PIXELFORMAT: color(16-bits) Z(16-bit) stencil(0-bits)
MODE: 4, 800 x 600 fullscreen hz:60
GAMMA: hardware w/ 0 overbright bits
CPU: Intel Pentium III
rendering primitives: multiple glArrayElement
texturemode: GL_LINEAR_MIPMAP_NEAREST
picmip: 2
texture bits: 16
multitexture: disabled
compiled vertex arrays: disabled
texenv add: disabled
compressed textures: disabled
Initializing Shaders
Setting up Shaders
----- finished R_Init -----
------- profiling DrawBackground methods -------
glDrawPixels w/ BGR: 7208396 clocks
glDrawPixels w/ RGB: 5764836 clocks
glTexSubImage2D w/ BGR: 3658916 clocks
glTexSubImage2D w/ RGB: 2862184 clocks
DrawBackground: using glTexSubImage2D with RGB data
-------------------------------
Setting up Shaders
----- finished CL_Vid_Restart_f ----
------- S_StopAllSounds (stop music) -------
------- S_StopAllSounds Complete-------
------ Server Initialization ------
Server: training
Called FadeSound with: 0.000000
Called FadeSound with: 0.000000
------- S_StopAllSounds (stop music) -------
------- S_StopAllSounds Complete-------
------- S_StopAllSounds (stop music) -------
------- S_StopAllSounds Complete-------
Called FadeSound with: 0.000000
Setting up Shaders
UI_DrawConnect called
------ Server Initialization Complete ------ 7.03 seconds
Called FadeSound with: 0.000000
------- Sound Begin Registration -------
------- S_StopAllSounds (stop music) -------
------- S_StopAllSounds Complete-------
------- Sound Begin Registration Complete -------


-----------PARSING UBERSOUND------------
Any SetCurrentTiki errors means that tiki wasn't prefetched and tiki-specific sounds for it won't work. To fix prefetch the tiki. Ignore if you don't use that tiki on this level.
Parse/Load time: 5.409000 seconds.
-------------UBERSOUND DONE---------------

-----------PARSING UBERDIALOG------------
Any SetCurrentTiki errors means that tiki wasn't prefetched and tiki-specific sounds for it won't work. To fix prefetch the tiki. Ignore if you don't use that tiki on this level.
Parse/Load time: 0.552000 seconds.
-------------UBERDIALOG DONE---------------

----- CL_Shutdown -----
Called FadeSound with: 0.000000
------- S_StopAllSounds (stop music) -------
------- S_StopAllSounds Complete-------
------- Sound Shutdown (full) -------
------- Sound Shutdown Complete -------
RE_Shutdown( 1 )
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...hiding window
...destroying window
...window successfully destroyed
...resetting display
...shutting down QGL
...unloading OpenGL DLL
-----------------------
----- Server Shutdown -----
---------------------------
WARNING: Medal of Honor requires a video card with multitexturing capability


Im going insane here! I have a NVIDIA GeForce2 with the latest drivers. And the game worked fine on my cousin's lesser comp..... Im really in a jam here.

Ctb
01-12-2003, 04:33 PM
How much memory does the card have?

1234!
01-12-2003, 10:13 PM
You may have the latest drivers but you dont use them.

Looking at the debug output, I see that you use the Scitechs GLDirect drivers which try to emulate OpenGL by mapping OpenGL calls to Direct3D calls.

Obviously the game is'nt happy with the features the GLDirect driver can offer.

The games REQUIRES support for 'GL_ARB_multitexture' which is not supported by GLDirect (see the log).

01-13-2003, 10:28 AM
Try this... goto www.nvidia.com (http://www.nvidia.com) and download the display drivers for GeForce3. This comes bundled with all the required stuff. Install that and everything should work fine.

charmidesmusic
01-17-2003, 08:00 PM
Hi "The Shingle"

I have the EXACT same problem as you with the GL thing then the intro and the mouse thing, then the NEW message that says something about multitexturing... i bought the game about three hours ago, and I'm still on the web trying to figure this thing out. I'll let you know if I find a solution, or let me know if you find a solution...

aol instant messenger screen name:
charmidesmusic